poj 1426 Find The Multiple ( dfs )

简介:

点击打开链接


Find The Multiple
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22234   Accepted: 9128   Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source


题目大意:
就是给你一个数 m,让你找只含有 0 和 1 的数而且是 m 的倍数的数

解题思路:
从网上看到的说最大的数不会超过18位,(m<=200),所以,可以直接用无符号位的数就行了,不涉及大数问题,
直接上dfs搞一下子,就行了,具体详见我代码:
/*
2015 - 09 - 09


Author: ITAK


Motto:
今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>


using namespace std;
bool ok;


/// t:表示0和1组成的数, k:位数,m:给定的数
void dfs(unsigned long long t, int k, int m)
{
    if(ok)///退出的标志
        return;
    if(t%m == 0)
    {
        cout<<t<<endl;
        ok = 1;
        return;
    }
    if(k == 19)
        return;
    dfs(t*10, k+1, m);///有可能是0
    dfs(t*10+1, k+1, m);///有可能是1
}


int main()
{
    int m;
    while(cin>>m,m)
    {
        ok = 0;
        dfs(1, 0, m);///从1开始搜,因为最高位是1
    }
    return 0;
}


目录
相关文章
|
1月前
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
19 0
|
9月前
|
机器学习/深度学习 Java
【Java每日一题,dfs】Find The Multiple
【Java每日一题,dfs】Find The Multiple
|
1月前
|
流计算
POJ 3620--Avoid The Lakes【DFS】
POJ 3620--Avoid The Lakes【DFS】
16 0
|
7月前
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
20 0
|
9月前
Find The Multiple(dfs和bfs都可)
Find The Multiple(dfs和bfs都可)
17 0
codeforces1244——D.Paint the Tree(dfs)
codeforces1244——D.Paint the Tree(dfs)
67 0
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
104 0
|
人工智能
poj2356:Find a multiple
题目链接: 【鸽巢原理+乱搞】 其实用不着开$map$ 一步最巧妙的转化是$……$前缀和。 反正本宝宝突发奇想就出来了。 首先,我们分类讨论。 1.当$∃i \in N_{+} $ 且 $i \in [1,n]$ 使 $a_{i} | n$ 则直接选这个数就好 2.没有以上那种特殊情况的话,我们记录前缀和$sum_{i}= \sum _{k=1}^{i} a_{k} (mod \ \ n)$ 然后又有两种情况。
1156 0