hdu 1019 Least Common Multiple

简介: hdu 1019 Least Common Multiple

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

 

 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

 

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

 

Sample Input

2


3 5 7 15

6 4 10296 936 1287 792 1

 

 

Sample Output

105


10296

 

就是求最小公倍数

 

代码:

#include<stdio.h>
int a[10000];
int MAX(int n)
{
int i,max=0;
for(i=0;i<n;i++)
if(max<a[i])
max=a[i];
return max;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
int i,j,s=1,f=0;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=2;i<=MAX(n);i++)
{
//    printf("max=%d\n",MAX(n));
for(j=0;j<n;j++)
if(a[j]%i==0) {a[j]/=i;f=1;}
if(f==1) {s*=i;i=1;}
f=0;
}
printf("%d\n",s);
}
return 0;
}
目录
相关文章
|
7月前
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
32 0
《Towards A Fault-Tolerant Speaker Verification System A Regularization Approach To Reduce The Condition Number》电子版地址
Towards A Fault-Tolerant Speaker Verification System: A Regularization Approach To Reduce The Condition Number
89 0
《Towards A Fault-Tolerant Speaker Verification System A Regularization Approach To Reduce The Condition Number》电子版地址
|
人工智能 BI
CF1169C. Increasing by Modulo(二分)
CF1169C. Increasing by Modulo(二分)
136 0
PAT (Advanced Level) Practice - 1143 Lowest Common Ancestor(30 分)
PAT (Advanced Level) Practice - 1143 Lowest Common Ancestor(30 分)
123 0
PAT (Advanced Level) Practice - 1068 Find More Coins(30 分)
PAT (Advanced Level) Practice - 1068 Find More Coins(30 分)
117 0
HDOJ1019Least Common Multiple
HDOJ1019Least Common Multiple
101 0
HDOJ 1019 Least Common Multiple(最小公倍数问题)
HDOJ 1019 Least Common Multiple(最小公倍数问题)
98 0
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
130 0
|
算法
HDOJ 1202 The calculation of GPA
HDOJ 1202 The calculation of GPA
122 0