POJ 3620--Avoid The Lakes【DFS】

简介: POJ 3620--Avoid The Lakes【DFS】


Avoid The Lakes

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7059   Accepted: 3748

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.


The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ KN × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: N, M, and K

* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5

3 2

2 2

3 1

2 3

1 1

Sample Output

4

Source

USACO 2007 November Bronze


题目分析:

纯粹的dfs  3 4  是3*4 的方阵  5是有5个湖       如果俩个湖临边就可以看做一个湖    

所以说问题就是让你求出以某个湖为起点看可以走多少步能走多少步就说明有多少个湖相连

输出最大的湖是多大

  hdu-1312-Red and Black

#include<cstdio>
#include<cstring>
int c,n,m,k,ans;
int map[110][110];
void dfs(int x,int y)
{
  
  if(map[x][y]) return ;  
  if(x>=1&&x<=n&&y>=1&&y<=m&&(!map[x][y]))
  {
    map[x][y]=1;
          ans++;
    dfs(x+1,y);
    dfs(x-1,y);
    dfs(x,y-1);
    dfs(x,y+1);
  }
  if(ans>c) c=ans;// 更新最大湖
}
int main()
{
  while(~scanf("%d%d%d",&n,&m,&k))
  {
    memset(map,1,sizeof(map));  //  把地图初始化为 1   1就是不能走
    int a,b;
    while(k--)
    {
      scanf("%d%d",&a,&b);
      map[a][b]=0;  //  把湖都初始化为  0   0就是能走
    }
    c=0;//  用来储存最大的湖
    for(int i=1;i<=n;i++)
    {
      for(int j=1;j<=m;j++)
      {
        if(!map[i][j])
        {
          ans=0;// 初始化步数
          dfs(i,j);  //  这里  i  j就是某个湖的位置传入dfs查他有多个相连的湖就是能走多少步和这个  hdu-1312  就一样了 
        }
          
      }
    }
    printf("%d\n",);
  }
  return 0;
}




目录
相关文章
|
1月前
Strange fuction(HDU--2899)
Strange fuction(HDU--2899)
|
10月前
|
算法
1091 zoj Knight Moves的BFS算法和DFS
1091 zoj Knight Moves的BFS算法和DFS
43 0
|
7月前
|
Java
hdu1016 Prime Ring Problem【素数环问题(经典dfs)】
hdu1016 Prime Ring Problem【素数环问题(经典dfs)】
28 0
|
9月前
Find The Multiple(dfs和bfs都可)
Find The Multiple(dfs和bfs都可)
15 0
HDU-1016,Prime Ring Problem(DFS+素数)
HDU-1016,Prime Ring Problem(DFS+素数)
AtCoder--755——dfs
题目描述 You are given an integer N. Among the integers between 1 and N (inclusive), how many Shichi-Go-San numbers (literally “Seven-Five-Three numbers”) are there? Here, a Shichi-Go-San number is a positive integer that satisfies the following condition:
87 0
【1094】The Largest Generation (树DFS-水题)
基础题。 这类题也是直接DFS,不是像上次的【1079】&【1090】供应树DFS一样是到了叶子结点就进行“更新/结算”类型,这题直接利用DFS统计每层的结点个数即可。
85 0
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
222 0