hdu-2680-Choose the best route(dijkstra)

简介: hdu-2680-Choose the best route(dijkstra)


Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10470    Accepted Submission(s): 3367


Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

 


Input

There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 


Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

 


Sample Input

      5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1      

 


Sample Output

      1 -1      

 


Author

dandelion

 


Source

2009浙江大学计算机研考复试(机试部分)——全真模拟

 


Recommend

lcy   |   We have carefully selected several similar problems for you:   2112  2544  1217  1142  1385

 


题目分析:

也是走模板但是要注意了,这个是单向图,好好看看单向图是怎么建表的


#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
#define M 1010
using namespace std;
int mark[M],dis[M],time[M][M];
int n,m,s;
void dijkstra(int s)
{
  memset(mark,0,sizeof(mark));
  memset(dis,INF,sizeof(dis));
  dis[s]=0;
  while(1)
  {
    int v=-1;
    for(int i=1;i<=n;i++)
        if(!mark[i]&&(v==-1||dis[i]<dis[v]))
           v=i;
    if(v==-1)  break;
    mark[v]=1;
    for(int i=1;i<=n;i++)
         dis[i]=min(dis[i],dis[v]+time[v][i]);
  }
}
int main()
{
  while(~scanf("%d%d%d",&n,&m,&s))
  {
    memset(time,INF,sizeof(time));
    while(m--)
    {
      int a,b,c;
      scanf("%d%d%d",&a,&b,&c);
      if(time[b][a]>c&&a!=b)
        time[b][a]=c;// 对就这里  单向建就行了,我这里是从终点查起点了所以反向建了
    }
    int w,st[M];
    scanf("%d",&w);
    for(int i=1;i<=w;i++)
      scanf("%d",&st[i]);
    int minn=INF;
    dijkstra(s);//  因为就一个终点但是起点不是一个,所以反向查比较省时间
    for(int i=1;i<=w;i++)
        minn=min(minn,dis[st[i]]);
      if(minn==INF)  printf("-1\n");
      else 
    printf("%d\n",minn);
  }
  return 0;
}


目录
相关文章
|
29天前
|
机器学习/深度学习 安全 Java
hdu-1596-find the safest road(dijkstra)
hdu-1596-find the safest road(dijkstra)
16 0
|
10月前
|
网络架构
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
POJ 3250 Bad Hair Day、POJ 2796 Feel Good(单调栈)
HDU7050.Link with Limit(有向图tarjan找环)
HDU7050.Link with Limit(有向图tarjan找环)
112 0
Leetcode-Easy 657. Judge Route Circle
Leetcode-Easy 657. Judge Route Circle
71 0
Leetcode-Easy 657. Judge Route Circle
|
机器学习/深度学习
HDU-2680,Choose the best route(Dijkstra)
HDU-2680,Choose the best route(Dijkstra)
|
算法 Go
HDU-1548,A strange lift(Dijkstra)
HDU-1548,A strange lift(Dijkstra)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
108 0
|
算法 机器学习/深度学习 消息中间件