HDU-2680,Choose the best route(Dijkstra)

简介: HDU-2680,Choose the best route(Dijkstra)

Problem Description:


One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.


Input:


There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.


Output:


The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.


Sample Input:


5 8 5


1 2 2


1 5 3


1 3 4


2 4 7


2 5 6


2 3 5


3 5 1


4 5 1


2


2 3


4 3 4


1 2 3


1 3 4


2 3 2


1


1


Sample Output:


1


-1


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f
int n,m,s;
int map[1001][1001],book[1001],dis[1001];
void Dijkstra(int v)
{
  int i,j,k,minn,u;
  memset(book,0,sizeof(book));
  book[v]=1;
  for(i=0;i<=n;i++)
    dis[i]=map[v][i];
  for(i=0;i<n;i++)
  {
    minn=INF;
    for(j=0;j<=n;j++)
    {
      if(book[j]==0&&dis[j]<minn)
      {
        u=j;
        minn=dis[j];
      }
    }
    book[u]=1;
    for(k=0;k<=n;k++)
    {
      if(map[u][k]<INF)
      {
        if(dis[k]>dis[u]+map[u][k])
          dis[k]=dis[u]+map[u][k];
      }
    }
  }
}
int main()
{
  int i,j,x,y,t,a,b;
  while(~scanf("%d %d %d",&n,&m,&s))
  {
    for(i=0;i<=n;i++)
    {
      for(j=0;j<=n;j++)
      {
        if(i==j)
          map[i][j]=0;
        else
          map[i][j]=INF;
      }
    }
    while(m--)
    {
      scanf("%d %d %d",&x,&y,&t);
      if(map[x][y]>t)
        map[x][y]=t;
    }
    scanf("%d",&a);
    while(a--)
    {
      scanf("%d",&b);
      map[0][b]=map[b][0]=0;
    }
    Dijkstra(0);
    if(dis[s]==INF)
      printf("-1\n");
    else
      printf("%d\n",dis[s]);
  }
  return 0;
}

 


相关文章
|
6月前
|
机器学习/深度学习 Java
hdu-2680-Choose the best route(dijkstra)
hdu-2680-Choose the best route(dijkstra)
29 0
|
6月前
|
机器学习/深度学习 安全 Java
hdu-1596-find the safest road(dijkstra)
hdu-1596-find the safest road(dijkstra)
40 0
|
Java
hdu1016 Prime Ring Problem【素数环问题(经典dfs)】
hdu1016 Prime Ring Problem【素数环问题(经典dfs)】
47 0
|
数据库 C语言
LeetCode 72. Edit Distance
给定两个单词word1和word2,找到将word1转换为word2所需的最小操作数。 您对单词允许以下3个操作: 插入一个字符 删除一个字符 替换一个字符
67 0
LeetCode 72. Edit Distance
HDU7050.Link with Limit(有向图tarjan找环)
HDU7050.Link with Limit(有向图tarjan找环)
139 0
|
算法 机器学习/深度学习 消息中间件
|
人工智能 Java