HDU-1050,Moving Tables(不用贪心也AC)

简介: HDU-1050,Moving Tables(不用贪心也AC)

Problem Description:


The famous ACM(Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.  

网络异常,图片无法展示
|

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.  


Input:


The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.


Output:


The output should contain the minimum time in minutes to complete the moving, one per line.


Sample Input:


3


4


10 20


30 40


50 60


70 80


2


1 3


2 200


3


10 100


20 80


30 50


Sample Output:


10


20


30


解题思路:


这题考的似乎是贪心算法,但是我参考了一种更简单的思路,贯彻本题的一句话,最大的交叉次数就是需要搬运的回合数!


假设从1到400(下标从1开始)的走廊是一条线段,每次搬一张桌子,假设从15号房间搬到25号房间,则区间15到25就重复了一次。然后另外再去搬一张桌子,假设这回从20号房间搬到30号房间,则区间20到30就重复了一次,相同的区间20到25就重复了两次,问题转化为求最大重复次数。


↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓


那就好办了,一个201大小的数组表示走廊位置(200个走廊位置),初始化为0,如果区间15到25重复了一次,则对15,16,17,18,19,20的走廊位置都加上1,第二次区间20到30又重复了,则又对20到30的位置加1。全部完成后,找出走廊最大值的位置,再乘以10分钟,就是所用的时间!



AC Code:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 201
int a[N];
int main()
{
  int t,n,start,end;
  cin>>t;
  while(t--)
  {
    memset(a,0,sizeof(a));
    cin>>n;
    for(int i=0;i<n;i++)
    {
      cin>>start>>end;
      if(start>end)
        swap(start,end);
      start=(start+1)/2;//这两行用来减少计算时间,缩小区间范围 
      end=(end+1)/2;//没有这两行就会RE 
      for(int j=start;j<=end;j++)
        a[j]++;
    }
    int maxn=0;
    for(int i=0;i<N;i++)
    {
      if(a[i]>maxn)
        maxn=a[i];
    }
    cout<<maxn*10<<endl;
  }
  return 0;
}


相关文章
|
存储 C语言
|
移动开发
洛谷P2639-[USACO09OCT]Bessie‘s Weight Problem G(01背包)
洛谷P2639-[USACO09OCT]Bessie‘s Weight Problem G(01背包)
洛谷P2639-[USACO09OCT]Bessie‘s Weight Problem G(01背包)
洛谷P3855-[TJOI2008]Binary Land(BFS)
洛谷P3855-[TJOI2008]Binary Land(BFS)
|
存储
Weekly Contest 107 AC思路
Weekly Contest 107 AC思路
1348 0