POJ-2488,A Knight's Journey(DFS)

简介: POJ-2488,A Knight's Journey(DFS)

Description:

 


网络异常,图片无法展示
|

BackgroundThe knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.


Input:


The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .


Output:


The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.


Sample Input:


3

1 1

2 3

4 3


Sample Output:


Scenario #1:

A1

 

Scenario #2:

impossible

 

Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4


题目大意:


给出一个pq列的国际棋盘,马可以从任意一个格子开始走,问马能否不重复的走完所有的棋盘。如果可以,输出按字典序排列出最小的路径。打印路径时,列用大写字母表示(A表示第一列),行用阿拉伯数字表示(从1开始),先输出列,再输出行。
分析:如果马可以不重复的走完所有的棋盘,那么它一定可以走到A1这个格子。所以我们只需从A1这个格子开始搜索,就能保证字典序是小的;除了这个条件,我们还要控制好马每次移动的方向,控制方向时保证字典序最小(即按照下图中格子的序号搜索)。控制好这两个条件,直接从A1开始搜索就行了。


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int map[101][101],vis[101][101],p,q,ans,flag;
int next1[8]={-1, 1,-2, 2,-2,2,-1,1};//分别为图中的八个点 
int next2[8]={-2,-2,-1,-1, 1,1, 2,2};//按照字典序定义每个点 
bool judge(int x,int y)
{
  if(x>=1&&x<=p&&y>=1&&y<=q&&!vis[x][y]&&!flag)
    return true;//在地图范围内,这个点没有走过,并且没有走完地图 
  return false;
}
void dfs(int x,int y,int step)
{
  map[step][0]=x;//横坐标 
  map[step][1]=y;//纵坐标 
  if(step==p*q)//此时已经走完整个地图 
  {
    flag=1;
    return ;
  }
  for(int i=0;i<8;i++)//八个方向去搜索吧!!! 
  {
    int tx=x+next1[i];
    int ty=y+next2[i];
    if(judge(tx,ty))
    {
      vis[tx][ty]=1;
      dfs(tx,ty,step+1);
      vis[tx][ty]=0;
    }
  }
}
int main()
{
  int n,ans=0;
  cin>>n;
  while(n--)
  {
    flag=0;
    cin>>p>>q;
    memset(vis,0,sizeof(vis));
    vis[1][1]=1;
    dfs(1,1,1);
    cout<<"Scenario #"<<++ans<<":"<<endl;
    if(flag)
    {
      for(int i=1;i<=p*q;i++)
        printf("%c%d",map[i][1]-1+'A',map[i][0]);
    }   //因为棋盘横纵坐标最大就是3,所以这个数减1再加上‘A’的ASCII码就可以了 
    else
      cout<<"impossible";
    cout<<endl;
    if(n)//注意题目的输出格式中的换行,避免PE 
      cout<<endl;
  }
  return 0;
}
相关文章
|
1月前
Knight Moves(POJ2243)
Knight Moves(POJ2243)
|
10月前
|
算法
1091 zoj Knight Moves的BFS算法和DFS
1091 zoj Knight Moves的BFS算法和DFS
43 0
AtCoder Beginner Contest 226 E - Just one(dfs求连通块 组合数学)
AtCoder Beginner Contest 226 E - Just one(dfs求连通块 组合数学)
86 0
2019CCPC秦皇岛HDU - 6736 F - Forest Program(dfs找环 组合数学)
2019CCPC秦皇岛HDU - 6736 F - Forest Program(dfs找环 组合数学)
83 0
AtCoder Beginner Contest 176 D - Wizard in Maze(01BFS)
AtCoder Beginner Contest 176 D - Wizard in Maze(01BFS)
96 0
|
算法
AtCoder Beginner Contest 213 E - Stronger Takahashi(01BFS)
AtCoder Beginner Contest 213 E - Stronger Takahashi(01BFS)
112 0
|
测试技术
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1026,Ignatius and the Princess I(BFS+打印路径)