HDU2319— Card Trick

简介: HDU2319— Card Trick

最近才看的STL—vector,所以就练练手手,写了一道类似的题。 ## 题目:J - Card Trick

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

1.The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.

2.Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.

3.Three cards are moved one at a time…

4.This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.


Input

On the first line of the input is a single positive integer, telling the number of test cases to follow. Each case consists of one line containing the integer n.


Output

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…


Sample Input

2

4

5


Sample Output


2 1 4 3

3 1 4 5 2

解题思路:

利用尾插法先把第一个数n输入进去,当输出的数组的长度不满足n时执行一下循环:把第n-i个数放在头部,把最后一个数放在头部,删除尾部的数,每一次循环让i++;

注意:最后一个尾数没有空格。

程序代码:

#include<vector>
#include<iostream>
using namespace std;
int main()
{
  vector<int> v;
  int i,n,m,k,b;
  cin>>k;
  for(int j=1;j<=k;j++)
  {
    cin>>n;
    v.push_back(n);
    i=1;
    while(v.size()!=n)
    {
      v.insert(v.begin(),n-i);
      m=n-i;
      while(m--)
      {
        v.insert(v.begin(),*(v.end()-1));
        v.erase(v.end()-1);
      }
      i++;  
    }
    for(i=0;i<n-1;i++)
      cout<<v[i]<<" ";
    cout<<v[n-1];
    cout<<endl;
    v.clear();  
  }
  return 0;
} 
 


vector用法不懂的可以参照上一篇博客















相关文章
|
8月前
|
机器学习/深度学习 安全 Java
hdu-1596-find the safest road(dijkstra)
hdu-1596-find the safest road(dijkstra)
52 0
|
8月前
|
知识图谱
Piggy-Bank(HDU--1114)
Piggy-Bank(HDU--1114)
Codeforces Round #192 (Div. 2) (330B) B.Road Construction
要将N个城市全部相连,刚开始以为是最小生成树的问题,其实就是一道简单的题目。 要求两个城市之间不超过两条道路,那么所有的城市应该是连在一个点上的,至于这个点就很好找了,只要找到一个没有和其他点有道路限制的即可。
53 0
|
机器学习/深度学习 网络架构
PTA 1164-1167 Good in C/Block Reversing/Summit/Cartesian Tree(一)
PTA 1164-1167 Good in C/Block Reversing/Summit/Cartesian Tree
110 0
PTA 1164-1167 Good in C/Block Reversing/Summit/Cartesian Tree(一)
|
机器学习/深度学习 网络架构
PTA 1164-1167 Good in C/Block Reversing/Summit/Cartesian Tree(二)
PTA 1164-1167 Good in C/Block Reversing/Summit/Cartesian Tree
129 0
|
人工智能
Educational Codeforces Round 98 (Rated for Div. 2)B-Toy Blocks
You are asked to watch your nephew who likes to play with toy blocks in a strange way. He has n boxes and the i-th box has ai blocks. His game consists of two steps: he chooses an arbitrary box i; he tries to move all blocks from the i-th box to other boxes.
270 0
|
人工智能 Java
|
Java 知识图谱