HDU2319— Card Trick

简介: HDU2319— Card Trick

最近才看的STL—vector,所以就练练手手,写了一道类似的题。 ## 题目:J - Card Trick

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

1.The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.

2.Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.

3.Three cards are moved one at a time…

4.This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.


Input

On the first line of the input is a single positive integer, telling the number of test cases to follow. Each case consists of one line containing the integer n.


Output

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…


Sample Input

2

4

5


Sample Output


2 1 4 3

3 1 4 5 2

解题思路:

利用尾插法先把第一个数n输入进去,当输出的数组的长度不满足n时执行一下循环:把第n-i个数放在头部,把最后一个数放在头部,删除尾部的数,每一次循环让i++;

注意:最后一个尾数没有空格。

程序代码:

#include<vector>
#include<iostream>
using namespace std;
int main()
{
  vector<int> v;
  int i,n,m,k,b;
  cin>>k;
  for(int j=1;j<=k;j++)
  {
    cin>>n;
    v.push_back(n);
    i=1;
    while(v.size()!=n)
    {
      v.insert(v.begin(),n-i);
      m=n-i;
      while(m--)
      {
        v.insert(v.begin(),*(v.end()-1));
        v.erase(v.end()-1);
      }
      i++;  
    }
    for(i=0;i<n-1;i++)
      cout<<v[i]<<" ";
    cout<<v[n-1];
    cout<<endl;
    v.clear();  
  }
  return 0;
} 
 


vector用法不懂的可以参照上一篇博客















相关文章
|
8月前
light oj 1231-1232 - 1233- Coin Change 背包
暂时到半懂不懂也没办法讲明白,就不误人子弟了,直接贴代码了。
23 0
|
8月前
|
算法
light oj 1047 - Neighbor House 动态规划
动态规划,这个和刘汝佳算法竞赛入门经典P158的数字三角形有些相似,不过是求最小的值,而且有些限制,每次走到点和上次走的点不在同一列。
19 0
|
8月前
Codeforces Round #192 (Div. 2) (330B) B.Road Construction
要将N个城市全部相连,刚开始以为是最小生成树的问题,其实就是一道简单的题目。 要求两个城市之间不超过两条道路,那么所有的城市应该是连在一个点上的,至于这个点就很好找了,只要找到一个没有和其他点有道路限制的即可。
22 0
|
10月前
UVa11565 - Simple Equations
UVa11565 - Simple Equations
39 0
|
机器学习/深度学习 人工智能 BI
Educational Codeforces Round 115 (Rated for Div. 2) D. Training Session(组合数学 思维)
Educational Codeforces Round 115 (Rated for Div. 2) D. Training Session(组合数学 思维)
88 0
|
人工智能 Windows
Educational Codeforces Round 113 (Rated for Div. 2) C - Jury Meeting (思维 组合数)
Educational Codeforces Round 113 (Rated for Div. 2) C - Jury Meeting (思维 组合数)
76 0
|
机器学习/深度学习 Java
codeforces Educational Codeforces Round 49 (Rated for Div. 2) C题
刚开始拿到这题很懵逼,知道了别人的思路之后开始写,但是还是遇到很多坑,要求求P2/S最大。p=a b。就是求(a2+ b2 +2ab)/ab最大,也就是a/b +b/a最大。那么题意就很明显了。
93 0
|
Java C语言
HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)
HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)
123 0
POJ 2390 Bank Interest
POJ 2390 Bank Interest
90 0