HDU-1208,Pascal's Travels

简介: HDU-1208,Pascal's Travels

Problem Description:


An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.



Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.

网络异常,图片无法展示
|



Figure 1

网络异常,图片无法展示
|



Figure 2


Input:


The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.


Output:


The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board.  


Sample Input:


4


2331


1213


1231


3110


4


3332


1213


1232


2120


5


11101


01111


11111


11101


11101


-1


Sample Output:


3


0


7


程序代码:


#include<stdio.h>
#include<string.h>
#define MAXN 50
char s[MAXN][MAXN];
int map[MAXN][MAXN];
long long dp[MAXN][MAXN];
int main()
{
  int n;
  while(~scanf("%d",&n)&&n!=-1)
  {
    memset(dp,0,sizeof(dp));
    for(int i=0;i<n;i++)
      scanf("%s",s[i]);
    for(int i=0;i<n;i++)
      for(int j=0;j<n;j++)
        map[i][j]=s[i][j]-'0';
    dp[0][0]=1;
    for(int i=0;i<n;i++)
    {
      for(int j=0;j<n;j++)
      {
        if(map[i][j]!=0)
        {
          if(map[i][j]+i<n)
            dp[i+map[i][j]][j]+=dp[i][j];
          if(map[i][j]+j<n)
            dp[i][j+map[i][j]]+=dp[i][j];
        }
      }
    }
    printf("%lld\n",dp[n-1][n-1]);
  }
  return 0;
}


相关文章
|
8月前
Strange fuction(HDU--2899)
Strange fuction(HDU--2899)
|
人工智能 Java
2021杭电多校5-Arrary-hdu7020
Array Time Limit: 15000/8000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others) Total Submission(s): 965 Accepted Submission(s): 312 Problem Description Given an integer array a[1…n].
184 0
2021杭电多校5-Arrary-hdu7020
|
机器学习/深度学习 自然语言处理
|
机器学习/深度学习 Java 网络架构
|
机器学习/深度学习
|
人工智能 机器学习/深度学习