Piggy-Bank(HDU--1114)

简介: Piggy-Bank(HDU--1114)

题目:

Before ACM can do anything, a budget must be prepared and the necessary financial

support obtained. The main income for this action comes from Irreversibly Bound Money

(IBM). The idea behind is simple. Whenever some ACM member has any small money, he

takes all the coins and throws them into a piggy-bank. You know that this process is

irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long

time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much

money is inside. So we might break the pig into pieces only to find out that there is not

enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to

weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given

currency. Then there is some minimum amount of money in the piggy-bank that we can

guarantee. Your task is to find out this worst case and determine the minimum amount of

cash

inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

解题思路:

题意描述:给出钱的总金额,然后再给出钱的种类的重量和价值,求满足的最小钱数

解题思路:这是一个完全背包的问题,有总钱量和每一种钱的价值和重量。可以先定义背包里面的价值都是最大,然后用min利用完全背包模板求最小金额。

程序代码:

#include<iostream>
#include<algorithm>
#include<string.h> 
using namespace std;
int a[6000],b[6000],dp[1000005];
int main()
{
  int i,j,k,m,n;
  int T,t;
  int inf=99999999;
  scanf("%d",&T);
  while(T--)
  {
    scanf("%d%d",&n,&m);
    k=m-n;
    scanf("%d",&n);
    for(i=0;i<n;i++)
      scanf("%d%d",&a[i],&b[i]);
    for(i=0;i<=k;i++)
      dp[i]=inf;
    dp[0]=0;
    for(i=0;i<n;i++)
           for(j=b[i];j<=k;j++)
                dp[j]=min(dp[j],dp[j-b[i]]+a[i]);
        if(dp[k]==inf)//如果最小金额是无穷大,就不存在这种可能。
          printf("This is impossible.\n");
        else
        printf("The minimum amount of money in the piggy-bank is %d.\n",dp[k]);
  }
  return 0;
} 
相关文章
|
7月前
|
应用服务中间件 C++ AHAS
hdu1327 Definite Values
hdu1327 Definite Values
30 0
|
24天前
|
Java 数据挖掘 知识图谱
HDU 1114 Piggy-Bank (完全背包)
HDU 1114 Piggy-Bank (完全背包)
14 0
POJ 2390 Bank Interest
POJ 2390 Bank Interest
90 0
|
算法 iOS开发
|
Java 知识图谱
|
人工智能 机器学习/深度学习
|
人工智能 Java
|
机器学习/深度学习 人工智能 BI
POJ 2390 Bank Interest
Problem Description Farmer John made a profit last year! He would like to invest it well but wonders how much money he will make.
805 0