【PAT甲级 - C++题解】1063 Set Similarity

简介: 【PAT甲级 - C++题解】1063 Set Similarity

1063 Set Similarity

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt×100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.


Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.


Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.


Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题意

给定若干集合,让我们计算询问的集合之间的相似度。


相似度计算公式为 N c / N t × 100 % N_c/N_t×100\%N c /N t ×100% ,其中 N c N_cN 表示两个集合交集的元素个数,而 N t N_tN   表示两个集合并集的元素个数。


思路

我们可以先将所有集合存进容器当中,然后再分别计算询问的集合的相似度。N c N_cN

c  可以遍历集合 a 中的元素,判断每个元素是否在集合 b 中从而计算出来。而 N t N_tN t  可以用集合 a 的元素个数加上集合 b 的元素个数,再减去 N c N_cN c  得到。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 110;
unordered_set<int> S[N];
int n, m;
int main()
{
    //输入每一个集合
    cin >> n;
    for (int i = 1; i <= n; i++)
    {
        cin >> m;
        while (m--)
        {
            int x;
            cin >> x;
            S[i].insert(x);
        }
    }
    //计算询问集合之间的相似度
    cin >> m;
    while (m--)
    {
        int a, b;
        cin >> a >> b;
        //计算两个集合交集元素的个数
        int nc = 0;
        for (auto& x : S[a])   nc += S[b].count(x);
        //计算两个集合并集元素的个数
        int nt = S[a].size() + S[b].size() - nc;
        //输出结果
        printf("%.1lf%%\n", (double)nc / nt * 100);
    }
    return 0;
}
目录
相关文章
|
1月前
|
C++ 容器
【C++】红黑树模拟实现STL中的map与set
【C++】红黑树模拟实现STL中的map与set
|
1月前
|
算法 测试技术 C++
【C++】map&set的底层结构 -- AVL树(高度平衡二叉搜索树)(下)
【C++】map&set的底层结构 -- AVL树(高度平衡二叉搜索树)(下)
|
1月前
|
C++ 容器
【C++】map&set的底层结构 -- AVL树(高度平衡二叉搜索树)(上)
【C++】map&set的底层结构 -- AVL树(高度平衡二叉搜索树)(上)
|
1月前
|
存储 C++ 容器
【C++】Map和Set -- 详解(下)
【C++】Map和Set -- 详解(下)
|
2天前
|
C++ 容器
C++之set/multiset容器
C++之set/multiset容器
6 1
|
3天前
|
存储 自然语言处理 C++
【C++航海王:追寻罗杰的编程之路】set|map|multiset|multimap简单介绍
【C++航海王:追寻罗杰的编程之路】set|map|multiset|multimap简单介绍
11 0
【C++航海王:追寻罗杰的编程之路】set|map|multiset|multimap简单介绍
|
7天前
|
存储 算法 NoSQL
C++一分钟之-map与set容器详解
【6月更文挑战第21天】C++ STL的`map`和`set`是基于红黑树的关联容器,提供有序存储和高效查找。`map`存储键值对,键唯一,值可重复;`set`仅存储唯一键。两者操作时间复杂度为O(log n)。常见问题包括键的唯一性和迭代器稳定性。自定义比较函数可用于定制排序规则,内存管理需注意适时释放。理解和善用这些工具能提升代码效率。
13 3
|
9天前
|
存储 编译器 C++
|
2天前
|
C++
【c++】map和set的封装
【c++】map和set的封装
5 0
|
2天前
|
存储 C++ 容器
【c++】set|map
【c++】set|map
4 0