【PAT甲级 - C++题解】1063 Set Similarity

简介: 【PAT甲级 - C++题解】1063 Set Similarity

1063 Set Similarity

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt×100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.


Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.


Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.


Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题意

给定若干集合,让我们计算询问的集合之间的相似度。


相似度计算公式为 N c / N t × 100 % N_c/N_t×100\%N c /N t ×100% ,其中 N c N_cN 表示两个集合交集的元素个数,而 N t N_tN   表示两个集合并集的元素个数。


思路

我们可以先将所有集合存进容器当中,然后再分别计算询问的集合的相似度。N c N_cN

c  可以遍历集合 a 中的元素,判断每个元素是否在集合 b 中从而计算出来。而 N t N_tN t  可以用集合 a 的元素个数加上集合 b 的元素个数,再减去 N c N_cN c  得到。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 110;
unordered_set<int> S[N];
int n, m;
int main()
{
    //输入每一个集合
    cin >> n;
    for (int i = 1; i <= n; i++)
    {
        cin >> m;
        while (m--)
        {
            int x;
            cin >> x;
            S[i].insert(x);
        }
    }
    //计算询问集合之间的相似度
    cin >> m;
    while (m--)
    {
        int a, b;
        cin >> a >> b;
        //计算两个集合交集元素的个数
        int nc = 0;
        for (auto& x : S[a])   nc += S[b].count(x);
        //计算两个集合并集元素的个数
        int nt = S[a].size() + S[b].size() - nc;
        //输出结果
        printf("%.1lf%%\n", (double)nc / nt * 100);
    }
    return 0;
}
目录
相关文章
|
2月前
|
存储 C++ 容器
【C++】map、set基本用法
本文介绍了C++ STL中的`map`和`set`两种关联容器。`map`用于存储键值对,每个键唯一;而`set`存储唯一元素,不包含值。两者均基于红黑树实现,支持高效的查找、插入和删除操作。文中详细列举了它们的构造方法、迭代器、容量检查、元素修改等常用接口,并简要对比了`map`与`set`的主要差异。此外,还介绍了允许重复元素的`multiset`和`multimap`。
36 3
【C++】map、set基本用法
|
2月前
|
存储 算法 C++
【C++】unordered_map(set)
C++中的`unordered`容器(如`std::unordered_set`、`std::unordered_map`)基于哈希表实现,提供高效的查找、插入和删除操作。哈希表通过哈希函数将元素映射到特定的“桶”中,每个桶可存储一个或多个元素,以处理哈希冲突。主要组成部分包括哈希表、哈希函数、冲突处理机制、负载因子和再散列,以及迭代器。哈希函数用于计算元素的哈希值,冲突通过开链法解决,负载因子控制哈希表的扩展。迭代器支持遍历容器中的元素。`unordered_map`和`unordered_set`的插入、查找和删除操作在理想情况下时间复杂度为O(1),但在冲突较多时可能退化为O(n)。
27 5
|
2月前
|
存储 C++ 容器
【C++】set模拟实现
C++中的`set`是STL提供的一种关联容器,用于存储唯一元素并自动按特定顺序(默认升序)排序。其内部通过红黑树实现,保证了高效的插入、删除和查找操作,时间复杂度均为O(log n)。`set`支持迭代器遍历,提供了良好的数据访问接口。
43 3
|
6月前
|
C++ 容器
【C++】map和set封装
【C++】map和set封装
47 2
|
6月前
|
存储 C++ 容器
【C++】map和set深度讲解(下)
【C++】map和set深度讲解(下)
70 2
|
6月前
|
存储 自然语言处理 Java
【C++】map和set深度讲解(上)
【C++】map和set深度讲解(上)
56 2
|
6月前
|
存储 C++ 容器
|
7月前
|
C++ 容器
C++之set/multiset容器
C++之set/multiset容器
|
7月前
|
存储 自然语言处理 C++
【C++航海王:追寻罗杰的编程之路】set|map|multiset|multimap简单介绍
【C++航海王:追寻罗杰的编程之路】set|map|multiset|multimap简单介绍
51 0
【C++航海王:追寻罗杰的编程之路】set|map|multiset|multimap简单介绍
|
7月前
|
存储 算法 NoSQL
C++一分钟之-map与set容器详解
【6月更文挑战第21天】C++ STL的`map`和`set`是基于红黑树的关联容器,提供有序存储和高效查找。`map`存储键值对,键唯一,值可重复;`set`仅存储唯一键。两者操作时间复杂度为O(log n)。常见问题包括键的唯一性和迭代器稳定性。自定义比较函数可用于定制排序规则,内存管理需注意适时释放。理解和善用这些工具能提升代码效率。
77 3