【PAT甲级 - C++题解】1068 Find More Coins

简介: 【PAT甲级 - C++题解】1068 Find More Coins

1068 Find More Coins

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.


Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤104, the total number of coins) and M (≤102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.


Output Specification:

For each test case, print in one line the face values V1≤V2≤⋯≤Vk such that V1+V2+⋯+Vk=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.


Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].


Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution


题意

给定需要支付的金额以及所有硬币的面额,判断是否能用这些硬币刚好凑齐支付的金额。

思路

状态表示: f [ i ] [ j ] f[i][j]f[i][j] 表示只考虑前 i 个物品,总体积为 j 的选法是否存在。


状态计算:


如果不选当前物品:f [ i ] [ j ] = f [ i − 1 ] [ j ] f[i][j] = f[i - 1][j]f[i][j]=f[i−1][j]


如果选当前物品:f [ i ] [ j ] ∣ = f [ i − 1 ] [ j − a [ i ] ] f[i][j] |= f[i - 1][j - a[i]]f[i][j]∣=f[i−1][j−a[i]]


这道题就是一个 01 背包问题,在计算完答案之后如果存在答案,则需要输出对应序列,就得从后往前判断每一个物品是否存在于答案序列中,如果存在就输出该值即可。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 10010, M = 110;
int a[N], f[N][M];
int n, m;
int main()
{
    cin >> n >> m;
    for (int i = 1; i <= n; i++)   cin >> a[i];
    //从大到小排序硬币面额
    sort(a + 1, a + n + 1, greater<int>());
    //动态规划计算是否存在答案
    f[0][0] = true;
    for (int i = 1; i <= n; i++)
        for (int j = 0; j <= m; j++)
        {
            f[i][j] = f[i - 1][j];
            if (j >= a[i]) f[i][j] |= f[i - 1][j - a[i]];
        }
    //判断是否存在答案,如果存在则输出答案序列 
    if (!f[n][m])    puts("No Solution");
    else
    {
        bool is_first = true;
        while (n)
        {
            if (m >= a[n] && f[n - 1][m - a[n]])
            {
                if (is_first)    is_first = false;
                else cout << " ";
                cout << a[n];
                m -= a[n];
            }
            n--;
        }
    }
    return 0;
}
目录
相关文章
|
5月前
|
算法 前端开发 大数据
【C/C++ 基础知识 】C++中易混淆的函数和关键字:std::find vs std::search,std::remove vs std::erase,remove vs delete
【C/C++ 基础知识 】C++中易混淆的函数和关键字:std::find vs std::search,std::remove vs std::erase,remove vs delete
98 0
|
5月前
|
存储 算法 JavaScript
【C++ 泛型编程 入门篇】 C++ 中的泛型算法 STL(sort,find)(二)
【C++ 泛型编程 入门篇】 C++ 中的泛型算法 STL(sort,find)
109 0
|
5月前
|
算法 搜索推荐 程序员
【C++ 泛型编程 入门篇】 C++ 中的泛型算法 STL(sort,find)(一)
【C++ 泛型编程 入门篇】 C++ 中的泛型算法 STL(sort,find)
95 0
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
61 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
77 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
70 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
69 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
74 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
73 0
|
16天前
|
编译器 C++
C++ 类构造函数初始化列表
构造函数初始化列表以一个冒号开始,接着是以逗号分隔的数据成员列表,每个数据成员后面跟一个放在括号中的初始化式。
60 30