【PAT甲级 - C++题解】1081 Rational Sum

简介: 【PAT甲级 - C++题解】1081 Rational Sum

1081 Rational Sum

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.


Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.


Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.


Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

ample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24


题意

给定 N 个有理数,格式为 分子/分母 ,请你计算它们的和。

保证答案中需要出现的所有数字都在 long long 范围内,且保证最终答案为非负数。

另外,如果给定的分数为负数,则符号在分子上。


思路

我们可以一个一个分数进行计算,用两个变量 a 和 b 来计算所有计算结果。


因为题目数据范围比较大,如果直接按照正常逻辑 a / b + c / d = ( a ∗ d + c ∗ b ) / b ∗ d a/b + c/d= (a*d+c*b)/b*da/b+c/d=(a∗d+c∗b)/b∗d 计算可能会爆 int ,我们需要拆分成三步防止爆 int :


1.先对给定的分数 c/d 进行化简。

2.然后进行运算,为了防止乘数过大,每次乘法前都除以一个 b 和 d 的最大公约数。

3.最后再对结果 a/b 进行化简。


代码

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
//求最大公约数
LL gcd(LL a, LL b)
{
    return b ? gcd(b, a % b) : a;
}
int main()
{
    LL a = 0, b = 1;
    int n;
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        LL c, d;
        scanf("%lld/%lld", &c, &d);
        //先对输入的分数进行化简
        LL t = gcd(c, d);
        c = c / t, d = d / t;
        //乘法可能会爆int,所以计算过程中也除以个最大公约数
        t = gcd(b, d);
        a = d / t * a + b / t * c;
        b = b / t * d;
        //最后再对结果进行化简
        t = gcd(a, b);
        a = a / t, b = b / t;
    }
    if (b == 1) printf("%lld\n", a);
    else
    {
        if (a >= b)    printf("%lld ", a / b), a %= b;
        printf("%lld/%lld\n", a, b);
    }
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
76 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
78 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
79 0
|
8天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
36 4
|
10天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
33 4
|
1月前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
27 4
|
1月前
|
编译器 C语言 C++
【C++打怪之路Lv4】-- 类和对象(中)
【C++打怪之路Lv4】-- 类和对象(中)
23 4