【PAT甲级 - C++题解】1010 Radix

简介: 【PAT甲级 - C++题解】1010 Radix

1010 Radix


Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.


Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix


Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:


For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10
• 1

Sample Output 1:

2


Sample Input 2:

1 ab 1 2
• 1

Sample Output 2:

Impossible

题意


N1 和 N 2 N2N2 是两个不超过 10 1010 位的数字,radix 是其中一个数字的进制,如果 tag 为 1 11,则 radix 是 N 1 N1N1 的进制,如果 tag 为 2 22,则 radix 是 N 2 N2N2 的进制。


输出使得 N 1 = N 2 N1=N2N1=N2 成立的另一个数字的进制数。


如果等式不可能成立,则输出 Impossible。


如果答案不唯一,则输出更小的进制数。

思路

这道题涉及到了秦九韶算法

假设给定一个 d 进制 abc ,那么我要转化成十进制的公式为:ad2+bd1+c放到循环中其实就是:

//假设n为字符串
long long res = 0;
for(auto x : n)
  res = res * d + x - '0';


1.png

代码

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
//将字符转换成数字
int get(char c)
{
    if (c <= '9')  return c - '0';
    return c - 'a' + 10;
}
//获得十进制值
LL calc(string n, LL r)
{
    LL res = 0;
    for (auto c : n)
    {
        //double存的数字比long long更大
        //如果已经大于1e16则一定大于target,直接返回一个超大值即可
        if ((double)res * r + get(c) > 1e16) return 1e18;
        res = res * r + get(c); //秦九韶算法
    }
    return res;
}
int main()
{
    string n1, n2;
    cin >> n1 >> n2;
    int tag, radix;
    cin >> tag >> radix;
    if (tag == 2)  swap(n1, n2);    //统一化处理
    LL target = calc(n1, radix);    //获得n1的十进制
    //获得二分的上边界和下边界
    LL l = 0, r = max(target, 36ll);
    for (auto c : n2)  l = max(l, (LL)get(c) + 1);
    //二分查找
    while (l < r)
    {
        LL mid = l + r >> 1;
        if (calc(n2, mid) >= target) r = mid;
        else    l = mid + 1;
    }
    if (calc(n2, r) == target) cout << r << endl;
    else puts("Impossible");
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
71 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
93 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
85 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
79 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
82 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
86 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
141 0
|
2月前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
65 2
|
2月前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
115 5
|
2月前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
118 4