hadoop 配置snappy失败:报错-问答-阿里云开发者社区-阿里云

开发者社区> kun坤> 正文

hadoop 配置snappy失败:报错

2020-06-20 11:55:54 237 1

我用的hadoop版本是Hadoop 2.6.0-cdh5.4.0 hadoop-snappy-0.0.1-SNAPSHOT\lib\native\Linux-amd64-64下编译好的文件放入hadoop的lib  文件夹下面  然后执行  hadoop  checknative  命令  看到 snappy 是false  求解啊


取消 提交回答
全部回答(1)
  • kun坤
    2020-06-20 11:55:59

    Hadoop 2.6的时候已经集成了snappy,大概注意点:

    1、保证本地装好了snappy本地库

    2、编译hadoop的时候加上 -Drequire.snappy

    3、hadoop-snappy.jar那个包不要了

    ######还有我是安装这个网址的资料装的 不知道对不对http://www.linuxidc.com/Linux/2014-05/101091.htm######能给个完整的安装步骤吗 ? 网上找的安装配置资料都太乱了。
    0 0
相关问答

4

回答

Spark 【问答合集】

社区小助手 2019-05-29 14:13:40 123744浏览量 回答数 4

10

回答

【精品问答合集】Hbase热门问答

hbase小能手 2019-05-29 14:37:26 120274浏览量 回答数 10

37

回答

SaaS模式云数据仓库MaxCompute 百问百答合集(持续更新20211202)

亢海鹏 2020-05-29 15:10:00 62195浏览量 回答数 37

20

回答

【阿里云产品公测】简单日志服务SLS使用评测含教程

mr_wid 2014-10-09 07:18:30 41043浏览量 回答数 20

5

回答

阿里云与Linode对比测试-阿里云与Linode选哪个好

roye888 2013-10-22 11:39:01 27117浏览量 回答数 5

9

回答

问几个小白问:服务器重置?数据恢复?及其他?

ap6681c6b 2012-08-15 20:47:42 37878浏览量 回答数 9

5

回答

java.lang.UnsupportedOperationException: This is supposed to be overridden by subclasses.

迷茫君 2019-07-16 09:26:11 118488浏览量 回答数 5

18

回答

MaxCompute百问集锦(持续更新20171011)

隐林 2017-06-30 18:30:36 50839浏览量 回答数 18

1

回答

【开源分享】-6期- Linkis 一款支持多种计算存储引擎的企业级计算中间件

montos 2020-05-08 10:55:23 28497浏览量 回答数 1

11

回答

速戳 | 20位阿里出题专家-备战阿里必不可少的题目

Runt 2020-04-15 10:54:04 56747浏览量 回答数 11
+关注
0
文章
13401
问答
相关电子书
更多
文娱运维技术
立即下载
《SaaS模式云原生数据仓库应用场景实践》
立即下载
《看见新力量:二》电子书
立即下载