希望云函数能在线安装 npm 依赖-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

希望云函数能在线安装 npm 依赖

console 2020-06-18 01:51:25 182

希望能在线安装 npm 依赖。因为我本地开发环境只有 windows 系统。有些 package 是需要本地编译的。

大家有好的实践吗?

Windows
分享到
取消 提交回答
全部回答(1)
  • python小菜菜
    2020-06-19 13:44:56

    前言 fun install 是 fun 工具的一个子命令,用于安装 pip 和 apt 依赖,提供了命令行接口和 Funfile 描述文件两种形式。

    安装 pip 包依赖 下面的命令安装 python 的 tensorflow 包

    $ fun install --runtime python2.7 --package-type pip tensorflow skip pulling image aliyunfc/runtime-python2.7:build-1.2.0... Task => [UNNAMED] => PYTHONUSERBASE=/code/.fun/python pip install --user tensorflow 说明

    --runtime 指定 runtime,如果已经初始化 fun.yml 文件, 由于 fun.yml 里声明了 runtime ,该选项可以省略。 --package-type 指定安装依赖的类型,pip 和 apt 是目前的两个可选值。 tensorflow 是一个 pip 包名。 命令执行在 fc-docker 提供的 container 中,容器内部执行的命令会逐行打印出来,比如上面命令中内部真实执行了 PYTHONUSERBASE=/code/.fun/python pip install --user tensorflow 命令。

    0 0
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题