需要帮助处理python 2.7和python 3上的beautifulsoup错误-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

需要帮助处理python 2.7和python 3上的beautifulsoup错误

is大龙 2020-03-23 20:21:37 269

我正在尝试设置BeautifulSoup4,以便可以运行以下命令:

from bs4 import BeautifulSoup

但是,当我安装BeautifulSoup4时,得到以下信息:

Defaulting to user installation because normal site-packages is not writeable. 
Requirement already satisfied: beautifulsoup4 in ./Library/Python/2.7/lib/python/site-packages (4.8.2)
Requirement already satisfied: soupsieve>=1.2 in ./Library/Python/2.7/lib/python/site-packages (from beautifulsoup4) (1.9.5)
Requirement already satisfied: backports.functools-lru-cache; python_version < "3" in ./Library/Python/2.7/lib/python/site-packages (from soupsieve>=1.2->beautifulsoup4) (1.6.1)

$ from bs4 import BeautifulSoup4
from: can't read /var/mail/bs4

在Python3中运行时,出现此错误

Python 3.8.2 
[Clang 6.0 (clang-600.0.57)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> from bs4 import beautifulsoup4
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: cannot import name 'beautifulsoup4' from 'bs4' (/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/bs4/__init__.py)

我的计算机上同时装有Python 3和Python 2.7,但无法弄清楚如何识别bs4

欣赏建议!

问题来源:stackoverflow

Python
分享到
取消 提交回答
全部回答(2)
  • 游客drl6uevi2k7uk
    2021-02-20 15:13:52

    设置虚拟环境做隔离,让不同的安装版本python有不用的运行环境,建议使用conda,耦合度低,可使用库和版本较多。

    0 0
  • is大龙
    2020-03-23 20:21:41

    在系统上拥有多个版本的Python会导致混乱,这是每个python开发人员在某个时候都会遇到的问题。

    为了解决您的问题,请尝试使用python -m命令安装bs4,例如python -m pip install beautifulsoup4。这样可以确保pip将软件包安装到您调用的python中。

    听起来好像是该了解虚拟环境的时候了。虚拟环境允许您为每个项目分离python实例,因此在程序包之间不会出现冲突。

    如果您想了解有关使用多个版本的python安装BeautifulSoup4的更多信息,请查看此问题。

    回答来源:stackoverflow

    0 0
添加回答
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程