开发者社区 > 大数据与机器学习 > 人工智能平台PAI > 正文

机器学习PAI在ODPS的PAI运行easy_rec,如何指定python版本为python3?

机器学习PAI在ODPS的PAI运行easy_rec,如何指定python版本为python3?

展开
收起
cuicuicuic 2023-11-19 14:58:25 23 0
3 条回答
写回答
取消 提交回答
  • 在ODPS的PAI运行easy_rec时,可以通过设置环境变量的方式来指定Python版本为Python3。具体步骤如下:

    1. 打开ODPS控制台,进入PAI工作空间。
    2. 点击“创建作业”,选择“easy_rec”模板。
    3. 在“参数配置”页面,找到“环境变量”一栏,点击“添加”。
    4. 在弹出的对话框中,输入变量名为“PYTHON_VERSION”,变量值为“python3”。
    5. 点击“确定”保存配置。
    6. 提交作业后,PAI会自动使用Python3来运行easy_rec。
    2023-11-29 16:08:24
    赞同 展开评论 打赏
  • 这个暂时还指定不了,此回答整理自钉群“【EasyRec】推荐算法交流群”

    2023-11-19 23:20:17
    赞同 展开评论 打赏
  • 面对过去,不要迷离;面对未来,不必彷徨;活在今天,你只要把自己完全展示给别人看。

    在 MaxCompute PAI 中,可以通过在命令行中指定 Python 版本来运行 easy_rec:

    pai -python3 easy_rec --help
    

    如果遇到问题,请确保安装了 Python 3.x 版本,并将 Python 3.x 添加到环境变量 PATH 中。可以使用以下命令检查是否安装了 Python 3.x:

    which python3
    

    如果找不到 Python 3.x,请使用以下命令安装:

    sudo apt-get install python3
    

    此外,可以在 ~/.bashrc 文件中添加以下代码,将 Python 3.x 添加到 PATH 中:

    export PATH=/usr/bin:$PATH
    
    2023-11-19 15:08:17
    赞同 展开评论 打赏

相关产品

  • 人工智能平台 PAI
  • 热门讨论

    热门文章

    相关电子书

    更多
    阿里云EMR2.0 平台:让大数据更简单 立即下载
    阿里云EMR 2.0:重新定义新一代开源大数据平台 立即下载
    2022年开源大数据热力报告 立即下载