如何在Xampp中安装PHP GD(GD Graphics Library)

简介: 如何在Xampp中安装PHP GD(GD Graphics Library)



如何在Xampp中安装PHP GD(GD Graphics Library)

  XAMPP是一个免费的、易于安装的Apache发行版,包含MariaDB、PHP和Perl。它允许您在计算机上的本地Web服务器上离线构建WordPress站点。它于2002年首次发布。

如何在Xampp中安装PHP GD(GD Graphics Library)

  它由ApacheFriends拥有,PHPGD图形库是一个用于动态处理图像的图形软件库。它的原生编程语言是ANSIC。

  推荐:什么是Apache?Apache Web服务器概述

GD Graphics Library

  PHP不仅限于创建HTML输出。它还可用于创建和处理各种不同图像格式的图像文件,包括GIF、PNG、JPEG、WEBP和XPM。PHP还可以直接将图像流输出到浏览器,需要使用GD图像函数库编译PHP才能使其工作。GD和PHP可能还需要其他库,具体取决于您要使用的图像格式。

如何在Xampp中安装PHP GD(GD Graphics Library)

  您可以使用PHP中的图像函数来获取JPEG、GIF、PNG、SWF、TIFF和JPEG2000图像的大小,通过exif扩展,您可以处理存储在JPEG和TIFF图像标题中的信息。通过这种方式,您可以读取数码相机生成的元数据,exif函数不需要GD库。

安装PHP GD

  在本文中,我们将了解如何在Xampp中安装PHP GD,可按照以下步骤在Xampp中安装PHP GD:

  1、从系统的任务栏中打开XAMPP控制面板,启动Apache和MySQL,点击Apache的配置Config

如何在Xampp中安装PHP GD(GD Graphics Library)

  2、点击php.ini将进一步打开一个文档文件。

  3、打开该文件搜索extension=fileinfo,

如何在Xampp中安装PHP GD(GD Graphics Library)

  4、在extension=fileinfo之后的下一行添加extension=gd,然后保存并关闭文件。

如何在Xampp中安装PHP GD(GD Graphics Library)

  5、再次导航到Xampp控制面板并重新启动apache服务器,就是这样现在PHP GD已成功安装在XAMPP中。

  推荐:如何在Apache服务器配置HTTP Security Headers安全标头

总结

  以上是晓得博客为你介绍的怎么在Xampp中安装PHP GD(GD Graphics Library)的全部内容,如有问题欢迎留言探讨。

  推荐:如何使用XAMPP搭建本地环境的WordPress网站

给文章评分


晓得博客,版权所有丨如未注明,均为原创

晓得博客 » 如何在Xampp中安装PHP GD(GD Graphics Library)

转载请保留链接:https://www.pythonthree.com/how-to-install-php-gd-in-xampp/

相关文章
|
2月前
|
Linux PHP
linux centos7 安装php7.4 实测 遇到的坑
linux centos7 安装php7.4 实测 遇到的坑
133 0
|
25天前
|
Ubuntu PHP Apache
蓝易云 - 如何在Ubuntu 22.04上安装PHP8.1并设置本地开发环境
以上就是在Ubuntu 22.04上安装PHP 8.1并设置本地开发环境的步骤。
36 2
|
1月前
|
存储 Linux PHP
PHP云盘网盘系统源码+快速对接多家云存储+全新一键安装版
快速对接多家云存储,支持七牛、又拍云、阿里云OSS、AWS S3、Onedrive、自建远程服务器,当然,还有本地存储。 自定义主题配色。 图片、音频、视频、文本、Markdown、Ofiice文档 在线预览。 移动端全站响应式布局。 文件、目录分享系统,可创建私有分享或公开分享链接。 用户个人主页,可查看用户所有分享。 多用户系统、用户组支持。 初步完善的后台,方便管理。 拖拽上传、分片上传、断点续传、下载限速(*实验性功能)。 多上传策略,可为不同用户组分配不同策略。 用户组基础权限设置、二步验证。 WebDAV协议支持。
23 2
|
1月前
|
Ubuntu PHP
ubuntu php libzip安装 ./configure报错 checking for libzip... not found configure
ubuntu php libzip安装 ./configure报错 checking for libzip... not found configure
23 1
|
1月前
|
Ubuntu 关系型数据库 MySQL
ubuntu apt 安装wordpress所需所有的 一键脚本 扩展您的PHP似乎没有安装运行WordPress所必需的MySQL扩展。
ubuntu apt 安装wordpress所需所有的 一键脚本 扩展您的PHP似乎没有安装运行WordPress所必需的MySQL扩展。
23 0
ubuntu apt 安装wordpress所需所有的 一键脚本 扩展您的PHP似乎没有安装运行WordPress所必需的MySQL扩展。
|
1月前
|
PHP Windows
windows 安装php7.4并配置phpstorm环境
windows 安装php7.4并配置phpstorm环境
72 0
|
2月前
|
应用服务中间件 PHP nginx
安装基于docker的php运行环境
安装基于docker的php运行环境
41 0
|
2月前
|
缓存 Linux PHP
yum安装PHP
yum安装PHP
194 3
|
2月前
|
关系型数据库 MySQL Linux
Centos7 yum安装lAMP 环境 php版本5.6.38 mysql版本5.7.22
Centos7 yum安装lAMP 环境 php版本5.6.38 mysql版本5.7.22
52 0
|
2月前
|
Ubuntu PHP
ubuntu16.04 卸载 php7并安装php5.6记录
ubuntu16.04 卸载 php7并安装php5.6记录