POJ-2524,Ubiquitous Religions(并查集模板题)

简介: POJ-2524,Ubiquitous Religions(并查集模板题)

Problem Description:


There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.


You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.  


Input:


The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.  


Output:


For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.


Sample Input:


10 9


1 2


1 3


1 4


1 5


1 6


1 7


1 8


1 9


1 10


10 4


2 3


4 5


4 8


5 8


0 0  

Sample Output:


Case 1: 1


Case 2: 7  


程序代码:  


#include<stdio.h>
#define MAXN 50001
int f[MAXN];
int getf(int v)
{
  if(f[v]==v)
    return v;
  else
  {
    f[v]=getf(f[v]);
    return f[v];
  }
}
void merge(int v,int u)
{
  int t1=getf(v);
  int t2=getf(u);
  if(t1!=t2)
    f[t2]=t1;
  return ;
}
int main()
{
  int n,m,ans=1;
  while(scanf("%d %d",&n,&m)!=EOF)
  {
    if(n==0&&m==0)
      break;
    for(int i=1;i<=n;i++)
      f[i]=i;
    int x,y,sum=0;
    while(m--)
    {
      scanf("%d %d",&x,&y);
      merge(x,y);
    }
    for(int i=1;i<=n;i++)
    {
      if(f[i]==i)
        sum++;
    }
    printf("Case %d: %d\n",ans++,sum);
  }
  return 0;
}


相关文章
|
8月前
poj 1990 MooFest 树状数组
题意就是有N头牛,每头牛都有一个坐标和声调值(x, v),两头牛之间通讯要花费的能量是他们的距离乘以最大的一个音调值,现在要任意两头牛之间都相互通讯一次,求总共需要花费多少能量?
26 0
|
9月前
|
算法
并查集模板题
并查集模板题
32 0
|
人工智能 网络架构
线段树-poj-2823
Sliding Window Description An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k
1064 0