poj 2524 Ubiquitous Religions(最简单的并查集)

简介:
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 17935   Accepted: 8748

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

复制代码
#include <iostream>
#include <stdio.h>

#define MAXNUM 50001
using namespace std;

//记录学生I所在宗教集合的父节点
int parent[MAXNUM];
//初始化
void init()
{
    for(int i = 1; i < MAXNUM; i++)
    parent[i] = i;
}

//找到a的父亲,即当前宗教集合的父亲
int find(int a)
{
    if(parent[a]==a)
    return a;
    //int tem = parent[a];
    parent[a] = find(parent[a]);//更新所有的节点的父亲:更新域并压缩路径
    return parent[a];
}
int main()
{
    //N个学生,M组
    int N,M;
    //学生I,学生J
    int I,J;
    //学生I、J所在宗教集合的根
    int ri,rj;

    int m;
    //case 计数
     m = 1;
    while(1)
    {
        init();
        scanf("%d%d",&N,&M);
        if(N==0&&M==0)break;

        while(M--)
        {
            scanf("%d%d",&I,&J);
            //if(I>N||J>N)continue;
            //找到宗教的根节点
            ri = find(I);
            rj = find(J);
            //若两个学生不在一个集合,合并,同时宗教数目较少一种
            if(ri!=rj)
            {
                //合并集合
                parent[ri] = rj;
                //宗教的种类减少一种
                N--;
            }
        }
        printf("Case %d: %d\n",m++,N);
    }
    return 0;
}
复制代码











本文转自NewPanderKing51CTO博客,原文链接: http://www.cnblogs.com/newpanderking/archive/2012/09/07/2676027.html  ,如需转载请自行联系原作者


相关文章
|
7月前
poj 1990 MooFest 树状数组
题意就是有N头牛,每头牛都有一个坐标和声调值(x, v),两头牛之间通讯要花费的能量是他们的距离乘以最大的一个音调值,现在要任意两头牛之间都相互通讯一次,求总共需要花费多少能量?
20 0
|
人机交互
POJ-2524,Ubiquitous Religions(并查集模板题)
POJ-2524,Ubiquitous Religions(并查集模板题)
|
人工智能 网络架构
线段树-poj-2823
Sliding Window Description An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k
1058 0

热门文章

最新文章