HDOJ 1040 As Easy As A+B

简介: HDOJ 1040 As Easy As A+B

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!


Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.

It is guarantied that all integers are in the range of 32-int.


Output

For each case, print the sorting result, and one line one case.


Sample Input

2

3 2 1 3

9 1 4 7 2 5 8 3 6 9


Sample Output

1 2 3

1 2 3 4 5 6 7 8 9


就是排序!按照升序排

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int m = sc.nextInt();
            int[] a = new int[m];
            for(int i=0;i<m;i++){
                a[i]=sc.nextInt();
            }
            for(int i=0;i<m-1;i++){
                for(int j=i+1;j<m;j++){
                    if(a[j]<a[i]){
                        int temp=a[j];
                        a[j]=a[i];
                        a[i]=temp;
                    }
                }
            }
            System.out.print(a[0]);
            for(int i=1;i<m;i++){
                System.out.print(" "+a[i]);
            }
            System.out.println();
        }
    }
}
目录
相关文章
In Search of an Easy Problem
In Search of an Easy Problem
89 0
In Search of an Easy Problem
HDOJ 2055 An easy problem
HDOJ 2055 An easy problem
110 0
|
Java 文件存储
HDOJ(HDU) 2132 An easy problem
HDOJ(HDU) 2132 An easy problem
105 0
|
Java 文件存储
HDOJ(HDU) 2123 An easy problem(简单题...)
HDOJ(HDU) 2123 An easy problem(简单题...)
167 0
HDOJ 1405 The Last Practice
HDOJ 1405 The Last Practice
96 0
HDOJ 2029 Palindromes _easy version(回文串)
HDOJ 2029 Palindromes _easy version(回文串)
110 0
HDOJ 1002 A + B Problem II
HDOJ 1002 A + B Problem II
116 0
HDOJ 2101 A + B Problem Too
HDOJ 2101 A + B Problem Too
102 0
|
Shell
HDOJ 1846 Brave Game
HDOJ 1846 Brave Game
120 0
HDOJ(HDU) 1678 Shopaholic
HDOJ(HDU) 1678 Shopaholic
106 0