HDOJ 1040 As Easy As A+B

简介: HDOJ 1040 As Easy As A+B

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!


Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.

It is guarantied that all integers are in the range of 32-int.


Output

For each case, print the sorting result, and one line one case.


Sample Input

2

3 2 1 3

9 1 4 7 2 5 8 3 6 9


Sample Output

1 2 3

1 2 3 4 5 6 7 8 9


就是排序!按照升序排

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int m = sc.nextInt();
            int[] a = new int[m];
            for(int i=0;i<m;i++){
                a[i]=sc.nextInt();
            }
            for(int i=0;i<m-1;i++){
                for(int j=i+1;j<m;j++){
                    if(a[j]<a[i]){
                        int temp=a[j];
                        a[j]=a[i];
                        a[i]=temp;
                    }
                }
            }
            System.out.print(a[0]);
            for(int i=1;i<m;i++){
                System.out.print(" "+a[i]);
            }
            System.out.println();
        }
    }
}
目录
相关文章
|
7月前
|
Java C++
hdoj 1715 大菲波数
先java代码
31 1
|
机器学习/深度学习
HDOJ 2074 叠筐
HDOJ 2074 叠筐
96 0
HDOJ 2034 人见人爱A-B
HDOJ 2034 人见人爱A-B
110 0
HDOJ 1214 圆桌会议
HDOJ 1214 圆桌会议
79 0
|
测试技术
HDOJ 2046 骨牌铺方格
Problem Description 在2×n的一个长方形方格中,用一个1× 2的骨牌铺满方格,输入n ,输出铺放方案的总数. 例如n=3时,为2× 3方格,骨牌的铺放方案有三种,如下图: Input 输入数据由多行组成,每行包含一个整数n,表示该测试实例的长方形方格的规格是2×n (0 import java.
702 0
|
Java
HDOJ 1234
开门人和关门人 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7142    Accepted Submission(s): 3656 Problem Description 每天第一个到机房的人要把门打开,最后一个离开的人要把门关好。
767 0