HDOJ(HDU) 2132 An easy problem

简介: HDOJ(HDU) 2132 An easy problem

Problem Description

We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.

Now there is a very easy problem . I think you can AC it.

We can define sum(n) as follow:

if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;

Is it very easy ? Please begin to program to AC it..-_-


Input

The input file contains multilple cases.

Every cases contain only ont line, every line contains a integer n (n<=100000).

when n is a negative indicate the end of file.


Output

output the result sum(n).


Sample Input

1

2

3

-1


Sample Output

1

3

30


水题。。注意范围。!!!java用long型可以AC,只是注意中间计算结果也有可能溢出int型范围,也要转换为long才行。

还有,注意判断条件退出不是输入-1,而是输入小于0的数就是退出了。

import java.util.Scanner;
public class Main{
    static long db[] = new long[100001];
    public static void main(String[] args) {
        dabiao();
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n<0){
                return;
            }
            System.out.println(db[n]);
        }
    }
    private static void dabiao() {
        db[1]=1;
        db[2]=3;
        for(int i=3;i<db.length;i++){
            if(i%3==0){
                db[i]=db[i-1]+i*(long)i*i;
                //这里的i*i要强转成long,long*int还是long,否则i*i*i会超int范围
            }else{
                db[i]=db[i-1]+i;
            }
        }
    }
}
目录
相关文章
|
7月前
|
算法 C++
POJ 3740 Easy Finding题解
这篇文章提供了一个使用舞蹈链(Dancing Links)算法解决POJ 3740 "Easy Finding" 问题的C++代码实现,该问题要求找出矩阵中能够使每一列都恰好包含一个1的行集合。
uva 11991 - Easy Problem from Rujia Liu?
这个题目的意思是输入n个数,m组询问,每组询问包含两个整数k,v,意思是询问整数v第k次出现的位置。
50 0
UVa1531 - Problem Bee
UVa1531 - Problem Bee
64 0
|
Java 文件存储
HDOJ(HDU) 2123 An easy problem(简单题...)
HDOJ(HDU) 2123 An easy problem(简单题...)
194 0
HDOJ 2055 An easy problem
HDOJ 2055 An easy problem
122 0
|
数据挖掘
HDOJ 1032(POJ 1207) The 3n + 1 problem
HDOJ 1032(POJ 1207) The 3n + 1 problem
143 0
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
141 0
|
Java 文件存储 关系型数据库
HDOJ(HDU) 2132 An easy problem
Problem Description We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
1096 0
【HDU 5572 An Easy Physics Problem】计算几何基础
2015上海区域赛现场赛第5题。 题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=5572 题意:在平面上,已知圆(O, R),点B、A(均在圆外),向量V。
1051 0