HDOJ 1405 The Last Practice

简介: HDOJ 1405 The Last Practice

Problem Description

Tomorrow is contest day, Are you all ready?

We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.


Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.

what does this problem describe?

Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.


Input

Input file contains multiple test case, each case consists of a positive integer n(1< n<65536), one per line. a negative terminates the input, and it should not to be processed.


Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.


Sample Input

60

12

-1


Sample Output

Case 1.

2 2 3 1 5 1


Case 2.

2 2 3 1


Hint

60=2^2*3^1*5^1


它说的是一些素数!不是全部是素数!既然是从小到大,所以从2开始遍历到根号(n)就可以了。如果最后n还是大于1的,说明n没除完,还剩余一个n^1.


格式!!!

每行的最后一定有一个空格。

各行之间有一个空行!

Case n.!!!数字后面有一个‘.’点。。。

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int tm = 0;
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n<0){
                return ;
            }
            if(tm>0){
                System.out.println();
            }
            System.out.println("Case "+(++tm)+".");
            for(int i=2;i<=Math.sqrt(n);i++){
                int num = 0;
                while(n%i==0){
                    n=n/i;
                    num++;
                }
                if(num!=0){
                    System.out.print(i+" "+num+" ");
                }
            }
            if(n>1){
                System.out.print(n+" 1 ");
            }
            System.out.println();
        }
    }
}
目录
相关文章
hdoj 1907
这是一道博弈的题,准确说是尼姆博弈,只要判断各项的异或值即可。
42 0
HDOJ 1405 The Last Practice
HDOJ 1405 The Last Practice
86 0
HDOJ 1017 A Mathematical Curiosity
HDOJ 1017 A Mathematical Curiosity
116 0
|
安全 数据安全/隐私保护
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
114 0
|
Java 文件存储
HDOJ(HDU) 2123 An easy problem(简单题...)
HDOJ(HDU) 2123 An easy problem(简单题...)
186 0
|
Java 文件存储
HDOJ(HDU) 2132 An easy problem
HDOJ(HDU) 2132 An easy problem
124 0
HDOJ 1002 A + B Problem II
HDOJ 1002 A + B Problem II
125 0
HDOJ 2101 A + B Problem Too
HDOJ 2101 A + B Problem Too
112 0
|
Java
HDOJ 1000 A + B Problem
HDOJ 1000 A + B Problem
118 0
|
Java 数据安全/隐私保护
HDOJ 2100 Lovekey
HDOJ 2100 Lovekey
106 0