HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)

简介: HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)

Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)

Your task is to take a number as input, and print that Fibonacci number.


Input

Each line will contain an integers. Process to end of file.


Output

For each case, output the result in a line.


Sample Input

100


Sample Output

4203968145672990846840663646


Note:

No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.


就是根据这个公式:

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)


输入一个n,输出f(n)的值。


注意,这是大数~答案的位数高达2005位~~~


再一次体会Java大数的强大吧~

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    static BigInteger f[] = new BigInteger[7045];
    public static void main(String[] args) {
        dabiao();
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n =sc.nextInt();
            System.out.println(f[n]);
            //System.out.println("---------");
            //System.out.println(f[n].toString().length());
            //开数组~看开到多少位的时候,位数大于2005
        }
    }
    private static void dabiao() {
        f[1]=new BigInteger("1");
        f[2]=new BigInteger("1");
        f[3]=new BigInteger("1");
        f[4]=new BigInteger("1");
        for(int i=5;i<f.length;i++){
            f[i]=f[i-1].add(f[i-2]).add(f[i-3]).add(f[i-4]);
        }
    }
}
目录
相关文章
|
6月前
D - 11(逆元好题)
D - 11(逆元好题)
|
6月前
|
C++
【PTA】​ L1-080 乘法口诀数列​(C++)
【PTA】​ L1-080 乘法口诀数列​(C++)
92 0
【PTA】​ L1-080 乘法口诀数列​(C++)
Fibonacci数列的多种求法
Fibonacci数列的多种求法
72 0
51nod 1189 阶乘分数(数论)
51nod 1189 阶乘分数(数论)
55 0
51nod 1711 平均数(二分 + 树状数组好题)
51nod 1711 平均数(二分 + 树状数组好题)
95 0
蓝桥杯-Fibonacci数列(打表)
蓝桥杯-Fibonacci数列(打表)
|
Java
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
99 0
|
Java
HDOJ/HDU 1865 1sting(斐波拉契+大数~)
HDOJ/HDU 1865 1sting(斐波拉契+大数~)
100 0
HDOJ(HDU) 2504 又见GCD(利用最大公约数反推)
HDOJ(HDU) 2504 又见GCD(利用最大公约数反推)
104 0