CentOS7 64位安装Mysql教程(二)

简介: 从最新版本的Linux系统开始,默认的是 Mariadb而不是mysql!这里依旧以mysql为例进行展示

这是因为缺少组件,解决办法:6.png

4、重置密码

重置密码前,首先无密码登录

    # mysql -u root

    登录时有可能报这样的错:ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’

    原因是/var/lib/mysql的访问权限问题。下面的命令把/var/lib/mysql的拥有者改为当前用户:

      # sudo chown -R openscanner:openscanner /var/lib/mysql

      如果报chown: 无效的用户: "openscanner:openscanner"错误,更换命令,并用 ll 查看目录权限列表

      7.png



      8.jpg

      注:
      ① 更改文件拥有者 (chown )

        # chown 账号名称 文件或目录

        ② 改变文件的用户组用命令 chgrp

          # chgrp 组名 文件或目录

          ③ 对于目录权限修改之后,默认只是修改当前级别的权限。如果子目录也要递归需要加R参数

            # Chown -R : 进行递归,连同子目录下的所有文件、目录


            然后,重启服务:

              # service mysqld restart

              接下来登录重置密码:

                # mysql -u root -p

                9.png

                重启mysql服务后才生效

                  # service mysqld restart

                  必要时加入以下命令行,为root添加远程连接的能力。链接密码为 “root”(不包括双引号)

                    mysql> GRANT ALL PRIVILEGES ON *.* TO root@"%" IDENTIFIED BY "root";

                    6、查询数据库编码格式,确保是 UTF-8

                      mysql> show variables like "%char%";


                      10.jpg

                      相关实践学习
                      每个IT人都想学的“Web应用上云经典架构”实战
                      本实验从Web应用上云这个最基本的、最普遍的需求出发,帮助IT从业者们通过“阿里云Web应用上云解决方案”,了解一个企业级Web应用上云的常见架构,了解如何构建一个高可用、可扩展的企业级应用架构。
                      MySQL数据库入门学习
                      本课程通过最流行的开源数据库MySQL带你了解数据库的世界。   相关的阿里云产品:云数据库RDS MySQL 版 阿里云关系型数据库RDS(Relational Database Service)是一种稳定可靠、可弹性伸缩的在线数据库服务,提供容灾、备份、恢复、迁移等方面的全套解决方案,彻底解决数据库运维的烦恼。 了解产品详情: https://www.aliyun.com/product/rds/mysql 
                      相关文章
                      |
                      安全 关系型数据库 MySQL
                      CentOS 7 yum 安装 MySQL教程
                      在CentOS 7上安装MySQL 8,其实流程很清晰。首先通过官方Yum仓库来安装服务,然后启动并设为开机自启。最重要的环节是首次安全设置:需要先从日志里找到临时密码来登录,再修改成你自己的密码,并为远程连接创建用户和授权。最后,也别忘了在服务器防火墙上放行3306端口,这样远程才能连上。
                      2736 16
                      |
                      存储 关系型数据库 MySQL
                      在CentOS 8.x上安装Percona Xtrabackup工具备份MySQL数据步骤。
                      以上就是在CentOS8.x上通过Perconaxtabbackup工具对Mysql进行高效率、高可靠性、无锁定影响地实现在线快速全量及增加式数据库资料保存与恢复流程。通过以上流程可以有效地将Mysql相关资料按需求完成定期或不定期地保存与灾难恢复需求。
                      910 10
                      |
                      存储 关系型数据库 MySQL
                      【免费动手教程上线】阿里云RDS MySQL推出大容量高性能存储:高性能本地盘(最高16TB存储空间)、高性能云盘(最高64TB存储空间)
                      阿里云RDS MySQL提供高性能本地盘与高性能云盘等存储方案,满足用户大容量、低延迟需求。高性能本地盘单盘最大16TB,IO延时微秒级;高性能云盘兼容ESSD特性,支持IO性能突发、BPE及16K原子写等能力。此外,阿里云还提供免费动手体验教程,帮助用户直观感受云数据库 RDS 存储性能表现。
                      |
                      缓存 关系型数据库 MySQL
                      百度搜索:蓝易云【CentOS8服务器安装MySQL报错:no match mysql-community-server】
                      现在,你已经成功安装了MySQL服务器并解决了"no match mysql-community-server"的报错问题。祝你使用愉快!
                      622 1
                      |
                      Linux 数据库管理 Python
                      CentOS7编译安装Python3.10(含OpenSSL1.1.1安装),创建虚拟环境,运行Django项目(含sqlite版本报错)
                      CentOS7编译安装Python3.10(含OpenSSL1.1.1安装),创建虚拟环境,运行Django项目(含sqlite版本报错)
                      2899 4
                      |
                      网络协议 Linux
                      CentOS7 yum安装报错“Could not resolve host: mirrorlist.centos.org;"之解决办法(换源)
                      CentOS7 yum安装报错“Could not resolve host: mirrorlist.centos.org; Name or service not known“之解决办法(换源)
                      |
                      缓存 Linux 编译器
                      【C++】CentOS环境搭建-安装log4cplus日志组件包及报错解决方案
                      通过上述步骤,您应该能够在CentOS环境中成功安装并使用log4cplus日志组件。面对任何安装或使用过程中出现的问题,仔细检查错误信息,对照提供的解决方案进行调整,通常都能找到合适的解决之道。log4cplus的强大功能将为您的项目提供灵活、高效的日志管理方案,助力软件开发与维护。
                      903 0
                      |
                      缓存 Linux 开发工具
                      CentOS7 安装KDE报错的解决方法:Loaded plugins:fastestmirror,langpacks There is no installed group.
                      CentOS7 安装KDE报错的解决方法:Loaded plugins:fastestmirror,langpacks There is no installed group.
                      1361 0
                      |
                      Linux Shell Swift
                      django(二)centos安装django3.2报错SQLite 3.8.3 or later is required (found 3.7.17)
                      我正在参加「掘金·启航计划」 Centos安装diango3.2框架请参照《django(一)ubuntu18.04安装框架》 在运行: 复制代码 python3 manage.py runserver 0.0.0.0:81 的时候报错: swift 复制代码 django.core.exceptions.ImproperlyConfigured: SQLite 3.8.3 or later is required (found 3.7.17). 报错的大体意思是:对sqlite最低版本的需求的3.8.3,但是现在只找到了3.7.17。
                      675 1