HDU 1856

简介: More is better Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others) Total Submission(s): 6073    Accepted Submission(s): 2225 Problem Description Mr Wang w

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 6073    Accepted Submission(s): 2225


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
 
 
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
 
 
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 

Author
lxlcrystal@TJU
 

Source
 
 #include"stdio.h"
int p[10000010], num[10000010]={0};

int find(int x)
{
    int k, j, r;
          r = x;
    while(r != p[r])
        r = p[r];
    k = x;
    while(k != r)            //注意这里的路径压缩
    {
        j = p[k];
        p[k] = r;
        k = j;
    }
    return r;
}

long count ()
{
    long i, max = 0 ;
    for (i = 1 ; i <= 10000000 ; i++) num[i] = 0 ;
    for (i = 1 ; i <= 10000000 ; i++) num[find(i)]++ ;              //用数组存放
    for (i = 1 ; i <= 10000000 ; i++) if (num[i] > max) max = num[i] ;
    return max ;
}
int main()
{
    long n, p1, p2, i, max = 0, j, cnt;
    while(scanf("%d", &n) != EOF)
    {
        for(i = 1; i <= 10000000; i++)
            p[i] = i;
        i = 1;
        while(i <= n)
        {
            scanf("%ld%ld", &p1, &p2);
            if(find(p1) != find(p2))
            {
                 p[find(p2)]=find(p1);
            }
            i++;
        }

        printf("%ld\n", count());
    }
    return 0;
}


目录
相关文章
|
7月前
|
机器学习/深度学习 存储 人工智能
HDU - 5912——Fraction
HDU - 5912——Fraction
|
Java 测试技术
hdu 1228 A + B
hdu 1228 A + B
51 0
|
人工智能 Java
hdu 1712 ACboy needs your help
ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。
141 0
HDU 2549 壮志难酬
壮志难酬 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 12541    Accepted Submission(s): 4166 Problem Description 话说MCA山上各路豪杰均出山抗敌,去年曾在江湖威名显赫的,江湖人称的甘露也不甘示弱,“天将降大任于斯人也,必先劳其筋骨,饿其体肤,空乏其身”他说。
1030 0
HDU&#160;1166
Description C国的死对头A国这段时间正在进行军事演习,所以C国间谍头子Derek和他手下Tidy又开始忙乎了。A国在海岸线沿直线布置了N个工兵营 地,Derek和Tidy的任务就是要监视这些工兵营地的活动情况。
1087 0