HDU-1037 Keep on Truckin'

简介: HDU-1037 Keep on Truckin'

题目:

description:

Boudreaux and Thibodeaux are on the road again …

“Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!”

“Don’t worry, Thibodeaux, I already checked ahead. There are three  underpasses and our 18-wheeler will fit through all of them, so just  keep that motor running!”

“We’re not going to make it, I say!”

So, which is it: will there be a very messy accident on Interstate  10, or is Thibodeaux just letting the sound of his own wheels drive him  crazy?

Input:

Input to this problem will consist of a single data set. The data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers,  separated by single spaces. Each number represents the height of a  single underpass in inches. Each number will be between 0 and 300  inclusive.

Output:

There will be exactly one line of output. This line will be:

NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

CRASH X

otherwise, where X is the height of the first underpass in the data  set that the 18-wheeler is unable to go under (which means its height is  less than or equal to the height of the 18-wheeler). The height of the  18-wheeler is 168 inches.

Sample Input

180 160 170

Sample Output

CRASH 160

解析:

1. 题目,地底隧道的最低高度是否满足要求

#include<stdio.h>
int main(){
   int a[3],min;
   while(scanf("%d %d %d",&a[0],&a[1],&a[2])!=EOF)
   {
       min=a[0];
       for(int i=0;i<3;i++)
       {
           if(min>a[i])
           {
               min=a[i];
           }
       }
       if(min<168)
       {
           printf("CRASH %d\n",min);
       }
       else
       {
            printf("NO CRASH\n");
       }
   }
   return 0;
}


相关文章
|
6月前
|
Java
HDU-1896-Stones
HDU-1896-Stones
27 0
|
算法 Java
HDU 2084 数塔
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的: 有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
174 0
|
Java BI
HDU 1412 {A} + {B}
{A} + {B} Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 19833    Accepted Submission(s): 8245 Problem Description 给你两个集合,要求{A} + {B}.
837 0
|
算法 Java 文件存储
|
机器学习/深度学习
hdu 2604 Queuing
点击打开hdu 2604 思路: 递推+矩阵快速幂 分析; 1 根据题目的意思,我们可以求出F[0] = 0 , F[1] = 2 , F[2] = 4 , F[3] = 6 , F[4] = 9 , F[5] = 15 2 那么根据上面...
799 0
|
固态存储
hdu 2333 Assemble
点击打开链接hdu 2333 思路:二分答案 分析: 1 首先我们遇到这类无从下手的题目的时候,我们首先应该考虑的就是利用二分答案,其它我们无从下手。
863 0