HDU-1037 Keep on Truckin'

简介: HDU-1037 Keep on Truckin'

题目:

description:

Boudreaux and Thibodeaux are on the road again …

“Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!”

“Don’t worry, Thibodeaux, I already checked ahead. There are three  underpasses and our 18-wheeler will fit through all of them, so just  keep that motor running!”

“We’re not going to make it, I say!”

So, which is it: will there be a very messy accident on Interstate  10, or is Thibodeaux just letting the sound of his own wheels drive him  crazy?

Input:

Input to this problem will consist of a single data set. The data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers,  separated by single spaces. Each number represents the height of a  single underpass in inches. Each number will be between 0 and 300  inclusive.

Output:

There will be exactly one line of output. This line will be:

NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

CRASH X

otherwise, where X is the height of the first underpass in the data  set that the 18-wheeler is unable to go under (which means its height is  less than or equal to the height of the 18-wheeler). The height of the  18-wheeler is 168 inches.

Sample Input

180 160 170

Sample Output

CRASH 160

解析:

1. 题目,地底隧道的最低高度是否满足要求

#include<stdio.h>
int main(){
   int a[3],min;
   while(scanf("%d %d %d",&a[0],&a[1],&a[2])!=EOF)
   {
       min=a[0];
       for(int i=0;i<3;i++)
       {
           if(min>a[i])
           {
               min=a[i];
           }
       }
       if(min<168)
       {
           printf("CRASH %d\n",min);
       }
       else
       {
            printf("NO CRASH\n");
       }
   }
   return 0;
}


相关文章
|
8月前
|
Java 测试技术
HDU-1233-还是畅通工程
HDU-1233-还是畅通工程
42 0
畅通工程 HDU - 1232
畅通工程 HDU - 1232
86 0
|
算法 Java 人工智能
|
机器学习/深度学习 算法
|
机器学习/深度学习 人工智能
HDU 2674
  题意:求N!mod2009,N=41时,N!因式分解一定含7*7*41,即N!%2009=0.所以只要计算0
721 0
hdu 1305 Immediate Decodability
点击打开链接hdu1305 思路:字典树 分析: 1 题目要求的是是否有一个字符串作为其它字符串的前缀 2 利用字典树的性质在插入的时候就可以判断某一个字符串是否是其它字符串或当前字符串是其它字符串的前缀 3 多组数据利用静态分配不能用动态分配。
753 0