开发者社区> jerrywangsap> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

Fedora CentOS Red Hat中让vim支持语法高亮设置

简介: Fedora / CentOS / Red Hat这三个系统里默认的vi是没有语法高亮显示的,白色的字体看起来很不舒服。 首先用命令行cat /etc/os-release查看当前linux系统的类型,发现为Red Hat: 使用命令行yum install vim-enhanced下载vi的增强版本: vim --version,确认这个版本确实有syntax支持。
+关注继续查看

Fedora / CentOS / Red Hat这三个系统里默认的vi是没有语法高亮显示的,白色的字体看起来很不舒服。

首先用命令行cat /etc/os-release查看当前linux系统的类型,发现为Red Hat:

使用命令行yum install vim-enhanced下载vi的增强版本:

vim --version,确认这个版本确实有syntax支持。

在 ~/.bashrc中将vim设置成vi的别名,下次再用vi即可享受语法高亮了。

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
Centos中git的安装
 CentOS的yum源中没有git,只能自己编译安装,现在记录下编译安装的内容,留给自己备忘。 确保已安装了依赖的包 yum install curl yum install curl-devel yum install zlib-devel
750 0
Centos 6.4 安装erlang&rabbitmq
原文地址: http://www.cnblogs.com/balaamwe/p/3678527.html 1. 安装 erlang 1.1 准备工作,先安装依赖库 yum -y install make gcc gcc-c++ kernel-devel m4 n...
603 0
【PHP扩展】centos给PHP安装扩展
本文由点点点细雨原创,禁止转载。 Memcache [root@localhost ~]# yum install libmemcached [root@localhost ~]# yum install memcached [root@localhost ~]# memcached...
899 0
centos安装vim7.4
转载于:http://www.cnblogs.com/nhlinkin/p/3545509.html    系统版本centos6.4; root权限 su - root     卸载 $ rpm -qa | grep vim $ yum remove vim vim-enhance...
682 0
Linux(CentOS)系统下安装好apache(httpd)服务后,其他电脑无法访问的原因
原文: Linux(CentOS)系统下安装好apache(httpd)服务后,其他电脑无法访问的原因 今天试了下在虚拟机上利用CentOS系统的yum命令安装好了httpd(apache2.4.6),然后在windows系统下访问此虚拟机的ip地址,却访问不了。
765 0
Centos 6.4 安装erlang&rabbitmq
原文地址: http://www.cnblogs.com/balaamwe/p/3678527.html   1. 安装 erlang 1.1 准备工作,先安装依赖库 yum -y install make gcc gcc-c++ kernel-devel m4 ncurses-deve...
434 0
CentOS7安装VMware Tools
CentOS7安装VMware Tools 安装依赖包[root@localhost ~]# yum -y install perl gcc make kernel-headers kernel-devel 加载vmware tools 到CentOS7光驱CD-ROM点击菜单 虚拟机 ——> 安装VMware Tools(T).
2488 0
+关注
文章
问答
文章排行榜
最热
最新
相关电子书
更多
3D/AR技术在新零售商业场景中的应用
立即下载
新零售时代, 特步的供应链转型升级之路
立即下载
低代码开发师(初级)实战教程
立即下载