最大子列和问题

简介: 版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sinat_32502811/article/details/77850560 01-复杂度1 最大子列和问题(20 分)给定K个整数组成的序列{ N ​1 ​​ , N ​2 ​​ , …, N ​K ​​ },“连续子列”被定义为{ N ​i ​​ , N ​i+1 ​​ , …, N ​j ​​ },其中 1≤i≤j≤K。
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sinat_32502811/article/details/77850560

01-复杂度1 最大子列和问题(20 分)

给定K个整数组成的序列{ N
​1
​​ , N
​2
​​ , …, N
​K
​​ },“连续子列”被定义为{ N
​i
​​ , N
​i+1
​​ , …, N
​j
​​ },其中 1≤i≤j≤K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。
本题旨在测试各种不同的算法在各种数据情况下的表现。各组测试数据特点如下:
数据1:与样例等价,测试基本正确性;
数据2:102个随机整数;
数据3:103个随机整数;
数据4:104个随机整数;
数据5:105个随机整数;
输入格式:

输入第1行给出正整数K (≤100000);第2行给出K个整数,其间以空格分隔。
输出格式:

在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。
输入样例:

6
-2 11 -4 13 -5 -2
输出样例:

20

#include <stdio.h>

int MaxSubseqSum1(int A[], int N);
int MaxSubseqSum2(int A[], int N);//分治法
int MaxSubseqSum3(int A[], int N);//动态规划

int main() {
    int N;
    int A[100000];
    int Max= 0;
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
            scanf("%d", &A[i]);
    }
    Max = MaxSubseqSum3(A, N);
    if(Max < 0) Max = 0;
    printf("%d\n",Max);
    return 0;
}

int MaxSubseqSum1(int A[], int N) {
    int Sum, MaxSum;
    int i, j;
    MaxSum = 0;
    for (i = 0; i < N; i++) {
        Sum = 0;
        for (j = i; j < N; j++) {
            Sum += A[j];
            if (Sum > MaxSum) {
                MaxSum = Sum;
            }
        }
    }
    if (MaxSum < 0)
        MaxSum = 0;
    return MaxSum;
}

int Max3(int A, int B, int C) {
  return A > B ? A > C ? A : C : B > C ? B : C;
}
int DivideAndConquer(int List[], int left, int right) {
    int MaxLeftSum, MaxRightSum;
    int MaxLeftBorderSum, MaxRightBorderSum;
    int LeftBorderSum, RightBorderSum;
    int center, i;
    if (left == right) {
        if (List[left] > 0) return List[left];
        else return 0;
    }
    center = (left + right) / 2;
    MaxLeftSum = DivideAndConquer(List, left, center);
    MaxRightSum = DivideAndConquer(List, center + 1, right);
    MaxLeftBorderSum = 0;
    LeftBorderSum = 0;
    for (i = center; i >= left; i--) {
        LeftBorderSum += List[i];
        if (LeftBorderSum > MaxLeftBorderSum)
            MaxLeftBorderSum = LeftBorderSum;
    }
    MaxRightBorderSum = 0;
    RightBorderSum = 0;
    for (i = center + 1; i <= right; i++) {
        RightBorderSum += List[i];
        if (RightBorderSum > MaxRightBorderSum)
            MaxRightBorderSum = RightBorderSum;
    }
    return Max3(MaxLeftBorderSum + MaxRightBorderSum, MaxLeftSum, MaxRightSum);
}
int MaxSubseqSum2(int A[], int N) {
    return DivideAndConquer(A, 0, N - 1);
}
int MaxSubseqSum3(int A[], int N) {
    int ThisSum, MaxSum;
    int i;
    ThisSum = MaxSum = 0;
    for (i = 0; i < N; i++) {
        ThisSum += A[i];
        if (ThisSum > MaxSum)
            MaxSum = ThisSum;
        else if(ThisSum < 0)
        {
            ThisSum = 0;
        }
    }
    return MaxSum;
}

主要是写了三个算法。比较重要的是第二个分治法的理解和第三个动态规划的理解。二者的时间复杂度分别为O(nlogn)和O(n)

01-复杂度2 Maximum Subsequence Sum(25 分)

Given a sequence of K integers { N
​1 , N2, …, NK}. A continuous subsequence is defined to be { N
​i​​ , Ni+1, …, N​j} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:

10 1 4

#include <stdio.h>
#include <time.h>


int MaxSubseqSum3(int A[], int N);
int START;
int END;

int main() {
    int N;
    int A[10000];
    int j = 0;
    int Max,a,b;
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
        scanf("%d", &A[i]);
    }
    Max = MaxSubseqSum3(A, N);
    a = A[START];
    b = A[END];
    printf("%d %d %d\n", Max,a,b);
    return 0;
}
int MaxSubseqSum3(int A[], int N) {
    int ThisSum = 0;
    int MaxSum = -1;
    int i;
    int start = 0;int starttemp = 0;
    int end = N-1 ;int endtemp = 0;
    for (i = 0; i < N; i++) {
        ThisSum += A[i];

        if (ThisSum > MaxSum) {
            MaxSum = ThisSum;
            start = starttemp;
            end = i;
        }
        else if (ThisSum < 0){
            ThisSum = 0;
            starttemp = i + 1;
        }
    }
    if (MaxSum < 0) MaxSum = 0;
    START = start;
    END = end;
    return MaxSum;
}

这里主要用的是动态规划的算法,我认为比较重要的一点就是一开始就对最大和MaxSum设置为-1,这样在测试数列全为负数时比较好处理。

目录
相关文章
|
4月前
|
算法 C++
【算法】前缀和算法——和可被K整除的子数组
【算法】前缀和算法——和可被K整除的子数组
|
6月前
|
C++
给定一个长度为n的数列,将这个数列按从小到大的顺序排列。1<=n<=200
给定一个长度为n的数列,将这个数列按从小到大的顺序排列。1<=n<=200
|
6月前
|
人工智能 BI
【动态规划】最长非降子序列 01背包 插入加号
1. 计算给定整数序列的最长非升子序列。 2. 解决 0-1 背包问题,找出使总价值最大的物品组合。 3. 找出在整数中插入加号的方法,使得加号后的整数和最小。
37 0
|
7月前
|
机器学习/深度学习
【剑指offer】-和为S的连续正数序列-39/67
【剑指offer】-和为S的连续正数序列-39/67
|
7月前
|
算法 程序员
【算法训练-动态规划 二】【线性DP问题】连续子数组的最大和、乘积最大子数组、最长递增子序列
【算法训练-动态规划 二】【线性DP问题】连续子数组的最大和、乘积最大子数组、最长递增子序列
115 0
子数组问题总结(很多子数组求法类似,暴力求法)
子数组问题总结(很多子数组求法类似,暴力求法)
子数组问题总结(很多子数组求法类似,暴力求法)
剑指offer 64. 和为S的连续正数序列
剑指offer 64. 和为S的连续正数序列
68 0
|
算法
7-142 最大子列和问题
7-142 最大子列和问题
72 0
每日一题——乘积小于 K 的子数组
每日一题——乘积小于 K 的子数组
79 0
每日一题——乘积小于 K 的子数组
Day29——491.递增子序列、 46.全排列、47.全排列 II
Day29——491.递增子序列、 46.全排列、47.全排列 II
94 0