poj 1046 Color Me Less(水题)

简介:
Color Me Less
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 26432   Accepted: 12740

Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation 

Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.

Output

For each color to be mapped, output the color and its nearest color from the target set. 

If there are more than one color with the same smallest distance, please output the color given first in the color set.

Sample Input

0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1

Sample Output

(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)

Source

很水的一道题,这里只是在求开平方时次步可以免去,直接比较开平方数就可以判断大小,减少运算。
复制代码
#include <stdio.h>
typedef struct
{
    int r,g,b;
}Color;

Color color[16];

int main()
{
    Color c;
    int i;
    int min_dis,dis,index;
    for(i = 0; i < 16;i++)
    scanf("%d%d%d",&color[i].r,&color[i].g,&color[i].b);
    while(1)
    {
        scanf("%d%d%d",&c.r,&c.g,&c.b);
        min_dis = 10000000;
        if(c.r==-1&&c.g==-1&&c.b==-1)break;
        for(i = 0; i<16; i++)
        {
            dis = (color[i].r-c.r)*(color[i].r-c.r)+(color[i].g-c.g)*(color[i].g-c.g)+(color[i].b-c.b)*(color[i].b-c.b);
            if(dis<min_dis)
            {
                min_dis = dis;
                index = i;
            }
        }
        printf("(%d,%d,%d) maps to (%d,%d,%d)\n",c.r,c.g,c.b,color[index].r,color[index].g,color[index].b);
    }
    return 0;
}
复制代码

 











本文转自NewPanderKing51CTO博客,原文链接:http://www.cnblogs.com/newpanderking/archive/2012/10/03/2710902.html ,如需转载请自行联系原作者


相关文章
|
机器学习/深度学习
light oj 1005 - Rooks(组合数学)
组合数学解法 现在n行中选出m行,C(n,m),再在n列中选出m列随便放A(n,m),答案为C(n,m)*A(n,m)。
46 0
hdoj 1028/poj 2704 Pascal's Travels(记忆化搜索||dp)
有个小球,只能向右边或下边滚动,而且它下一步滚动的步数是它在当前点上的数字,如果是0表示进入一个死胡同。求它从左上角到右下角到路径数目。 注意, 题目给了提示了,要用64位的整数。
46 0
|
机器学习/深度学习 存储
light oj 1011 - Marriage Ceremonies (状态压缩+记忆化搜索)
light oj 1011 - Marriage Ceremonies (状态压缩+记忆化搜索)
48 0
|
存储 定位技术 C++
【PAT甲级 - C++题解】1091 Acute Stroke
【PAT甲级 - C++题解】1091 Acute Stroke
64 0
|
机器学习/深度学习
HDOJ/HDU 1556 Color the ball(树状数组)
HDOJ/HDU 1556 Color the ball(树状数组)
107 0
HDOJ 1312 (POJ 1979) Red and Black
HDOJ 1312 (POJ 1979) Red and Black
119 0
|
Java Go
POJ 1163 The Triangle
POJ 1163 The Triangle
111 0
poj-1046-color me less
Description A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform jus...
961 0