poj 1607 Deck(坑爹的水题啊)

简介:

Deck

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 745    Accepted Submission(s): 395


Problem Description
A single playing card can be placed on a table, carefully, so that the short edges of the card are parallel to the table's edge, and half the length of the card hangs over the edge of the table. If the card hung any further out, with its center of gravity off the table, it would fall off the table and flutter to the floor. The same reasoning applies if the card were placed on another card, rather than on a table. 

Two playing cards can be arranged, carefully, with short edges parallel to table edges, to extend 3/4 of a card length beyond the edge of the table. The top card hangs half a card length past the edge of the bottom card. The bottom card hangs with only 1/4 of its length past the table's edge. The center of gravity of the two cards combined lies just over the edge of the table. 

Three playing cards can be arranged, with short edges parallel to table edges, and each card touching at most one other card, to extend 11/12 of a card length beyond the edge of the table. The top two cards extend 3/4 of a card length beyond the edge of the bottom card, and the bottom card extends only 1/6 over the table's edge; the center of gravity of the three cards lines over the edges of the table. 

If you keep stacking cards so that the edges are aligned and every card has at most one card above it and one below it, how far out can 4 cards extend over the table's edge? Or 52 cards? Or 1000 cards? Or 99999?
 

 

Input
Input contains several nonnegative integers, one to a line. No integer exceeds 99999.
 

 

Output
The standard output will contain, on successful completion of the program, a heading: 

# Cards Overhang 

(that's two spaces between the words) and, following, a line for each input integer giving the length of the longest overhang achievable with the given number of cards, measured in cardlengths, and rounded to the nearest thousandth. The length must be expressed with at least one digit before the decimal point and exactly three digits after it. The number of cards is right-justified in column 5, and the decimal points for the lengths lie in column 12.
 

 

Sample Input
1 2 3 4 30
 

 

Sample Output
The line of digits is intended to guide you in proper output alignment, and is not part of the output that your solution should produce.
 
12345678901234567 
# Cards  Overhang 
    1     0.500 
    2     0.750 
    3     0.917 
    4     1.042 
   30     1.997
 

 

Source
采用打表法。
郁闷的是同样一个题,在hdu和zoj上边都通过了,在poj上边的输出略有不同,可是修改输出还是不行一直的wrong,因此这道题只是在zoj和hdu上边通过了。
hdu(1330)、zoj(1216)、poj(1607)同一个题,只是输出要求略有不同。可能是格式化的问题,不再追究了。
下边的代码是在zoj和hdu上通过的代码。
复制代码
#include <stdio.h>
#define MAX_NUM 100000

int main()
{
    int i;
    double num[MAX_NUM];
    double sum=0.0;
    int index;
    num[0] = 0.0;
    for(i=1;i<MAX_NUM;i++)
    {
        sum+=1.0/(i+i);
        num[i]=sum;
    }

    printf("# Cards  Overhang\n");
    while(scanf("%d",&index)!=EOF)
    printf("%5d%10.3lf\n",index,num[index]);
    return 0;
}
复制代码

 










本文转自NewPanderKing51CTO博客,原文链接:http://www.cnblogs.com/newpanderking/archive/2012/10/05/2712035.html ,如需转载请自行联系原作者



相关文章
|
3月前
|
Java Go 图形学
一篇文章讲明白HDU4044GeoDefense(动态规划)
一篇文章讲明白HDU4044GeoDefense(动态规划)
17 0
|
3月前
|
C++
【洛谷 P1428】小鱼比可爱 题解(循环)
这是一个编程竞赛问题,题目要求编写一个程序来计算每只鱼在其视野内看到的更不可爱的鱼的数量。给定鱼的总数`n`和每只鱼的可爱程度数组`a[]`,输出每个位置的鱼能看到的更不可爱的鱼的数量。 **摘要:** ```markdown 解决一个编程挑战,计算鱼在“比可爱”比赛中左边有多少条更不可爱的鱼。输入包含鱼的总数`n`和每条鱼的可爱度,输出每条鱼眼中更不可爱的鱼数。提供的C++代码通过遍历数组,比较每只鱼的可爱度并累计小于它的数量,然后输出结果。 ``` 这个摘要在240个字符以内,简要概述了问题的背景、任务和解决方案的概要。
32 0
|
4月前
|
人工智能
蛇形填数(蓝桥杯)
蛇形填数(蓝桥杯)
|
算法
【AcWing&&牛客】打表找规律
【AcWing&&牛客】打表找规律
79 0
|
移动开发 算法
『牛客|每日一题』N皇后问题
基础算法无论在研究生面试还是求职面试都是十分重要的一环,这里推荐一款算法面试神器:牛客网-面试神器;算法题只有多刷勤刷才能保持思路与手感,大家赶紧行动起来吧(温馨提示:常见的面试问答题库也很nice哦 https://www.nowcoder.com/link/pc_csdncpt_ll_sf
100 0
『牛客|每日一题』N皇后问题
|
网络架构
POJ-1005,I Think I Need a Houseboat(数学题)
POJ-1005,I Think I Need a Houseboat(数学题)