poj 1607 Deck(坑爹的水题啊)

简介:

Deck

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 745    Accepted Submission(s): 395


Problem Description
A single playing card can be placed on a table, carefully, so that the short edges of the card are parallel to the table's edge, and half the length of the card hangs over the edge of the table. If the card hung any further out, with its center of gravity off the table, it would fall off the table and flutter to the floor. The same reasoning applies if the card were placed on another card, rather than on a table. 

Two playing cards can be arranged, carefully, with short edges parallel to table edges, to extend 3/4 of a card length beyond the edge of the table. The top card hangs half a card length past the edge of the bottom card. The bottom card hangs with only 1/4 of its length past the table's edge. The center of gravity of the two cards combined lies just over the edge of the table. 

Three playing cards can be arranged, with short edges parallel to table edges, and each card touching at most one other card, to extend 11/12 of a card length beyond the edge of the table. The top two cards extend 3/4 of a card length beyond the edge of the bottom card, and the bottom card extends only 1/6 over the table's edge; the center of gravity of the three cards lines over the edges of the table. 

If you keep stacking cards so that the edges are aligned and every card has at most one card above it and one below it, how far out can 4 cards extend over the table's edge? Or 52 cards? Or 1000 cards? Or 99999?
 

 

Input
Input contains several nonnegative integers, one to a line. No integer exceeds 99999.
 

 

Output
The standard output will contain, on successful completion of the program, a heading: 

# Cards Overhang 

(that's two spaces between the words) and, following, a line for each input integer giving the length of the longest overhang achievable with the given number of cards, measured in cardlengths, and rounded to the nearest thousandth. The length must be expressed with at least one digit before the decimal point and exactly three digits after it. The number of cards is right-justified in column 5, and the decimal points for the lengths lie in column 12.
 

 

Sample Input
1 2 3 4 30
 

 

Sample Output
The line of digits is intended to guide you in proper output alignment, and is not part of the output that your solution should produce.
 
12345678901234567 
# Cards  Overhang 
    1     0.500 
    2     0.750 
    3     0.917 
    4     1.042 
   30     1.997
 

 

Source
采用打表法。
郁闷的是同样一个题,在hdu和zoj上边都通过了,在poj上边的输出略有不同,可是修改输出还是不行一直的wrong,因此这道题只是在zoj和hdu上边通过了。
hdu(1330)、zoj(1216)、poj(1607)同一个题,只是输出要求略有不同。可能是格式化的问题,不再追究了。
下边的代码是在zoj和hdu上通过的代码。
复制代码
#include <stdio.h>
#define MAX_NUM 100000

int main()
{
    int i;
    double num[MAX_NUM];
    double sum=0.0;
    int index;
    num[0] = 0.0;
    for(i=1;i<MAX_NUM;i++)
    {
        sum+=1.0/(i+i);
        num[i]=sum;
    }

    printf("# Cards  Overhang\n");
    while(scanf("%d",&index)!=EOF)
    printf("%5d%10.3lf\n",index,num[index]);
    return 0;
}
复制代码

 










本文转自NewPanderKing51CTO博客,原文链接:http://www.cnblogs.com/newpanderking/archive/2012/10/05/2712035.html ,如需转载请自行联系原作者



相关文章
|
8月前
蓝桥备战--分糖果OJ2928 贪心 分类讨论
蓝桥备战--分糖果OJ2928 贪心 分类讨论
73 0
|
8月前
【每日一题Day329】LC213打家劫舍Ⅱ | 动态规划
【每日一题Day329】LC213打家劫舍Ⅱ | 动态规划
48 0
|
8月前
【每日一题Day330】LC337打家劫舍Ⅲ | 动态规划
【每日一题Day330】LC337打家劫舍Ⅲ | 动态规划
44 0
蓝桥杯:翻硬币
蓝桥杯:翻硬币
74 0
《蓝桥杯每日一题》递推·AcWing 3777. 砖块
《蓝桥杯每日一题》递推·AcWing 3777. 砖块
82 0
PTA猴子选大王(约瑟夫环问题)
PTA猴子选大王(约瑟夫环问题)
136 1
|
人工智能
【蓝桥杯集训·每日一题】AcWing 3625. 幂次方
文章目录 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 三、知识风暴 快速幂
70 0
【蓝桥杯集训·每日一题】AcWing 3382. 整数拆分
文章目录 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 三、知识风暴 背包DP
92 0
|
C++
【寒假每日一题】AcWing 4728. 乘方
目录 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解
151 0