zoj 2433 Highways(英语是硬伤啊)

简介:
Highways
Time Limit: 2 Seconds       Memory Limit: 65536 KB       Special Judge

In a distant country Lineland there are N cities and they are all located along the highway. The highway is a straight line; it starts from the first city and runs through the second, third city and so on, ending in the N-th city. The i-th city is located at the distance of Xi miles from the first one.

The highway is wide and smooth, so it is a pleasure for all people to drive along it. But there is one problem - all roads in Lineland, including the highway, are one-way. So people are only allowed to drive along the highway from the city with smaller number to the city with greater number and they have to use country roads to get back, and that is not such a great pleasure indeed.

After the new president Mr. Pathwayson was elected in Lineland, he has decided that he would like to make it easier for people to get from one town to another. But he does not dare to change the traditions, and make the highway two-way. Therefore he has decided to build new highways to connect the cities, so that it would be possible to get from any city to any other one by highways. Traditionally, the new highways must be one-way.

Of course, Mr. Pathwayson is a great president, and he wants people to remember him in years. After a thought he has decided that building just one highway would not be enough for that. Therefore he has decided that he must build two new highways. Each highway would connect two different cities. Since people are anxious about their health, and cars running along the highway produce dangerous wastes, each new highway must not pass through any cities, except the cities it connects. Also building two new highways in one city would disturb people too much, so all the cities that would be the ends of the new highways must be different.

You are the assistant of the minister of transportation of Lineland, so you are asked to choose the cities to be connected by the new highways. Since the cost of building a highway is proportional to its length, the total length of the highways must be minimal possible. Write a program to solve this problem. You may assume that the distance between two cities along the new highway is equal to the distance between those cities along the main highway.


Input

The first line of the input contains N (2 <= N <= 50,000).

Next line contains N-1 integer numbers: X2, X3, ..., XN (1 <= X2 < X3 < ...< XN <= 10^9).


Output

If it is impossible to build the highways satisfying all requirements, print number 0 on the first line of the output.

In the other case on the first line of the output file print the minimal possible total length of the highways to be built. On the second line print S1, E1, S2 and E2 - the numbers of the cities to connect by the first and the second highway, respectively. Note that highways are one-way and must run from S1 to E1 and from S2 to E2.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input

1

4
3 5 10


Sample Output

12
3 1 4 2

分析:

(1)题意:有一条单行道,要你再建两条路,这两条路的首尾不能重合且覆盖全部旅程。其实题目的意思就是要找出N个数中相邻间距最小的两个数。

(2)注意输出格式

复制代码
#include <stdio.h>
#define MIN_NUM 1000000001

int main()
{
    int N,n,i,min,pre,cur,tem,index;
    scanf("%d",&N);
    while(N--)
    {
        scanf("%d",&n);
        min = MIN_NUM;
        pre = 0;
        for(i=1;i<n;i++)
        {
            scanf("%d",&cur);
            tem = cur - pre;
            pre = cur;
            if(i!=1&&i!=n-1&&tem < min)
            {
                min = tem;
                index = i;
            }
        }
        if(min==MIN_NUM)printf("0\n");
        else
        {
            printf("%d\n",cur+min);
            printf("%d 1 %d %d\n",index+1,n,index);
        }
        if(N)printf("\n");
    }
    return 0;
}
复制代码










本文转自NewPanderKing51CTO博客,原文链接:  http://www.cnblogs.com/newpanderking/archive/2012/10/05/2712239.html ,如需转载请自行联系原作者


相关文章
|
3月前
【每日一题Day282】LC2681英雄力量 | 排序+数学
【每日一题Day282】LC2681英雄力量 | 排序+数学
26 0
|
数据采集 小程序 数据挖掘
【我问 Crossin】英语不好能不能学编程?
IDLE 里点击保存或运行时,程序无响应,或弹出如下的弹窗
|
3月前
|
机器人
【每日一题Day343】LC2731移动机器人 | 脑筋急转弯+数学
【每日一题Day343】LC2731移动机器人 | 脑筋急转弯+数学
36 0
PTA 7-2 找奇葩 (20 分)
在一个长度为 n 的正整数序列中,所有的奇数都出现了偶数次,只有一个奇葩奇数出现了奇数次。你的任务就是找出这个奇葩。
95 0
高职考技能提升教程008期 掷骰子与冒泡排序 VB语言 刘金玉编程
高职考技能提升教程008期 掷骰子与冒泡排序 VB语言 刘金玉编程
|
C语言
【C语言】万恶PTA练习题之初入江湖
【C语言】万恶PTA练习题之初入江湖
280 0
|
测试技术
PTA 7-1 祖传好运 (15 分)
我们首先定义 0 到 9 都是好运数,然后从某个好运数开始,持续在其右边添加数字,形成新的数字。
116 0
|
搜索推荐 数据管理 关系型数据库
为了学习英语,我开发了一个单词对战系统
本系统主要由Android、服务端、数据管理端构成。客户端的页面实现通过网络与服务器REST API接口通信获取 MySQL数据。本人重点参与网上单词对战系统客户端、服务器以及数据库的设计、开发、测试工作。
278 0
为了学习英语,我开发了一个单词对战系统
|
存储 算法 调度
【CCCC】PAT : 团体程序设计天梯赛-练习集 L2 答案,题解,附代码
【CCCC】PAT : 团体程序设计天梯赛-练习集 L2 答案,题解,附代码
372 0
【CCCC】L2-029 特立独行的幸福 (25分),模拟题,set用法
【CCCC】L2-029 特立独行的幸福 (25分),模拟题,set用法
155 0