hdu 3635 Dragon Balls(并查集)

简介:

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1271    Accepted Submission(s): 516


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

 

Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

 

Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
 

 

Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
 
分析:
(1)这道题就是一个并查集,没什么特殊的,关键是记录转移次数  trans_times[a] += trans_times[tem]; // 更新传输次数,。要理解这句代码
(2)还有就是更新球所在城市的球的总数 city[y] += city[x]; 理解这行代码
(3)其他的都是简单的并查集的套路,这两行理解了,这道题就over了。。。
 
复制代码
#include <stdio.h>
#define MAX_NUM 10010
int N,Q;
//记录城市内龙珠数目
int city[MAX_NUM];
//球指向的集合
int root[MAX_NUM];

int trans_times[MAX_NUM];

int find_root(int a)
{
    if(root[a]==a)return a;
    else{
        int tem = root[a];
        root[a]=find_root(root[a]);
        trans_times[a] += trans_times[tem];//更新传输次数
        //改城市的球被转移到了root下,
        //那么这个城市的球数量减少1,而根城市的球的数量加1
        return root[a];
    }
}

void union_set(int a,int b)
{
    int x = find_root(a);
    int y = find_root(b);
    if(x==y)return;
    else{
        city[y] += city[x];
        root[x] = y;
        trans_times[x]++;
    }
}
void init()
{
    for(int i = 0; i <= N; i++)
    {
        root[i] = i;
        city[i] = 1;
        trans_times[i]=0;
    }
}

int main()
{
    int T;
    int x,y,fx,fy,z;
    char op;
    scanf("%d",&T);
    for(int t = 1; t <= T; t++)
    {
        scanf("%d %d",&N,&Q);
        init();
        printf("Case %d:\n",t);
        while(Q--)
        {
            getchar();
            scanf("%c",&op);
           // printf("%c",op);
            if(op=='T')
            {
                scanf("%d%d",&x,&y);
                fx = find_root(x);
                fy = find_root(y);
                if(fx!=fy)
                union_set(x,y);
            }else{
                scanf("%d",&z);
                find_root(z);
                printf("%d %d %d\n",root[z],city[root[z]],trans_times[z]);
            }
        }

    }
    return 0;
}
复制代码

 







本文转自NewPanderKing51CTO博客,原文链接:http://www.cnblogs.com/newpanderking/archive/2012/10/20/2732491.html ,如需转载请自行联系原作者



相关文章
|
6月前
|
Java
hdu 2503 a/b + c/d
hdu 2503 a/b + c/d
25 0
|
6月前
|
Java
hdu 1257 最少拦截系统
hdu 1257 最少拦截系统
21 0
|
人工智能
HDU6656——Kejin Player(期望DP+前缀和)
HDU6656——Kejin Player(期望DP+前缀和)
65 0
HDU6656——Kejin Player(期望DP+前缀和)
|
机器学习/深度学习
HDOJ/HDU 1556 Color the ball(树状数组)
HDOJ/HDU 1556 Color the ball(树状数组)
82 0