HDU-3635,Dragon Balls(有点难度的并查集。。。)

简介: HDU-3635,Dragon Balls(有点难度的并查集。。。)

Problem Description:


Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.





His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.


Input:


The first line of the input is a single positive integer T(0 < T <= 100).

For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).


Each of the following Q lines contains either a fact or a question as the follow format:

T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.

Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)


Output:


For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.


Sample Input:


2


3 3


T 1 2


T 3 2


Q 2


3 4


T 1 2


Q 1


T 1 3


Q 1


Sample Output:


Case 1:


2 3 0


Case 2:


2 2 1


3 3 2


程序代码:  


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 10001
int f[N];
int head[N];//记录每个龙珠的移动次数 
int tail[N];//记录每个城市的龙珠个数 
int getf(int v)
{
  if(f[v]==v)
    return v;
  else
  {
    int t=f[v];
    f[v]=getf(f[v]);
    head[v]+=head[t];//加上父节点的转移次数
    return f[v];
  }
}
void merge(int v,int u)
{
  int t1=getf(v);
  int t2=getf(u);
  if(t1!=t2)
  {
    f[t1]=t2;
    head[t1]++;//转移次数加1 
    tail[t2]+=tail[t1];//子节点的龙珠都给父节点 
  }
  return ;
}
int main()
{
  int t,n,q,i,ans=1;
  char s[5];
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d %d",&n,&q);
    for(i=1;i<=n;i++)
    {
      f[i]=i;
      head[i]=0;//转移次数初始化为0 
      tail[i]=1;//每个成熟龙珠个数初始化为1 
    }
    printf("Case %d:\n",ans++);
    for(i=1;i<=q;i++)
    {
      scanf("%s",s);
      if(s[0]=='T')
      {
        int x,y;
        scanf("%d %d",&x,&y);
        merge(x,y);
      }
      else
      {
        int m,x;
        scanf("%d",&x);
        m=getf(x);
        printf("%d %d %d\n",m,tail[m],head[x]);
      }
    }
  }
  return 0;
}


相关文章
codeforces1253——D. Harmonious Graph(并查集)
codeforces1253——D. Harmonious Graph(并查集)
74 0
|
机器学习/深度学习
HDU2376——Average distance(思维+树形DP)
HDU2376——Average distance(思维+树形DP)
76 0
AtCoder Beginner Contest 223 D - Restricted Permutation(建图 思维 构造 拓扑排序)
AtCoder Beginner Contest 223 D - Restricted Permutation(建图 思维 构造 拓扑排序)
94 0
|
人工智能 Java
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
Jumping Monkey Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 747 Accepted Submission(s): 360
196 0
[HDU 7136] Jumping Monkey | 并查集 | 逆向思维
UVa 11292 - Dragon of Loowater(排序贪心)
UVa 11292 - Dragon of Loowater(排序贪心)
80 0