mongodb启动很慢:[initandlisten] found 1 index(es) that

简介:

故障现象

mongodb启动后,等了几十分钟还一直没启动完成,单节点副本集,状态一直处于startup

原因分析:
查看mongod的错误日志,发现:[initandlisten] found 1 index(es) that wasn't finished before shutdown。
mongodb启动很慢:[initandlisten] found 1 index(es) that

根据错误日志的提示信息,看样子原因是这样的:在db关闭之前,有一二较大的索引建立的操作没有完成,db就直接shutdown了,等db再次启动的时候,mongo默认会将这个index重建好,重建期间处于startup状态
处理方法

由于不清楚building index到底要持续多久,根据错误日志提示,重启mongod时加上--noIndexBuildRetry参数来跳过索引重建。等启动完成后,再评估是否需要建立这个index。
mongodb启动很慢:[initandlisten] found 1 index(es) that

本文转自奔跑在路上博客51CTO博客,原文链接http://blog.51cto.com/qiangsh/2050112如需转载请自行联系原作者


qianghong000

相关文章
|
NoSQL Shell 数据库
Mongodb启动&关闭
mac 下mongo的启动和关闭以及启动问题解决 mongo的安装在这:http://www.cnblogs.com/leinov/p/6855784.html Mac os mongodb数据安装路径是 $ /data/db 2.
2431 0
|
NoSQL MongoDB
启动mongodb报错 Failed to set up listener: SocketException: Address already in use 解决办法
启动mongodb报错 Failed to set up listener: SocketException: Address already in use 解决办法
1683 1
|
NoSQL MongoDB 开发工具
启动mongodb 报错 Error: Failure while executing; `git clone https://github.com/Homebrew/homebrew-serv...
启动mongodb 报错 Error: Failure while executing; `git clone https://github.com/Homebrew/homebrew-serv...
1593 0
|
SQL NoSQL MongoDB
MongoDB数据的安装与启动
MongoDB数据的安装与启动
372 0
MongoDB数据的安装与启动
|
存储 运维 NoSQL
MongoDB大量集合启动加载优化原理
## 背景 启动数据加载时间对于很多数据库来说是一个不容忽视的因素,启动加载慢直接导致数据库恢复正常服务的RTO时间变长,影响服务可用性。比如Redis,启动时要加载RDB和AOF文件,把所有数据加载到内存中,根据节点内存数据量的不同,加载时间可能达到几十分钟甚至更长。MongoDB在启动时同样需要加载一些元数据,结合阿里云MongoDB云上运维的经验,在集合数量不多时,这个加载时间不会很长,但
1183 0
MongoDB大量集合启动加载优化原理
|
NoSQL Shell MongoDB
启动 MongoDB 服务
启动 MongoDB 服务
503 0
|
NoSQL 固态存储 Shell
MongoDB Oplog Stones 实现分析及启动加载优化
对 Oplog Stones 的实现和初始化流程进行了详细的分析,简单分析了 Oplog 回收的逻辑。并对 oplog stones 的启动加载流程进行了优化,对比有数量级提升。
20341 0
|
NoSQL Shell Linux
Linux下的MongoDB安装&启动&关闭
一、下载安装包 下载地址 二、解压安装包 $ tar -zxvf mongodb-linux-x86_64-3.0.6.tgz 三、复制到指定的目录下 $ mv mongodb-linux-x86_64-3.
5719 0

推荐镜像

更多