EIGRP综合小实验(负载均衡,默认路由重分布,手工路由汇总,含端口映射,DHCP等)--CCNP学习笔记

简介:

逻辑拓扑图

 

EIGRP综合小实验(负载均衡,默认路由重分布,手工路由汇总,含端口映射,DHCP等)--CCNP学习笔记

 

 

实验要求:

1.R1R3右边接口地址通过R4DHCP server学到地址

2.全网EIGRP,每台设备上起lo,地址为设备编号(比如R11.1.1.1/24

3.R3上起一个lo口,地址为100.100.100.100/24,不允许通告进EIGRP,但全网可达,而且必须用EIGRP实现

4.R5telneR4lo时跑到R2上去

5.R2下面的接口bandwidth512,实现负载均衡

6.R5上起lo10-20,手工精确汇总

 

 

 

 

 

 

R1配置:

R1#sh run

Building configuration...

 

Current configuration : 1153 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

no aaa new-model

memory-size iomem 5

!

ip cef

no ip domain lookup

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.0

!

interface Ethernet0/0

 ip address dhcp

 full-duplex

!

interface Serial1/0

 ip address 12.1.1.1 255.255.255.0

 serial restart-delay 0

!

router eigrp 100

 network 1.1.1.0 0.0.0.255

 network 12.1.1.0 0.0.0.255

 network 134.1.1.0 0.0.0.255

 no auto-summary

!

no ip http server

no ip http secure-server

!        

control-plane

!

line con 0

 logging synchronous

line aux 0

line vty 0 4

!

end

----------------------------------华丽分割线------------------------------

R1路由表:

R1#sh ip ro

 

Gateway of last resort is 134.1.1.2 to network 3.0.0.0

 

     1.0.0.0/24 is subnetted, 1 subnets

C       1.1.1.0 is directly connected, Loopback0

     2.0.0.0/24 is subnetted, 1 subnets

D       2.2.2.0 [90/2297856] via 12.1.1.2, 01:06:14, Serial1/0

D*   3.0.0.0/8 [90/409600] via 134.1.1.2, 01:06:20, Ethernet0/0

     4.0.0.0/24 is subnetted, 1 subnets

D       4.4.4.0 [90/409600] via 134.1.1.4, 01:28:10, Ethernet0/0

     5.0.0.0/24 is subnetted, 1 subnets

D       5.5.5.0 [90/2323456] via 134.1.1.4, 01:28:23, Ethernet0/0

     23.0.0.0/24 is subnetted, 1 subnets

D       23.1.1.0 [90/2195456] via 134.1.1.2, 01:06:17, Ethernet0/0

     12.0.0.0/24 is subnetted, 1 subnets

C       12.1.1.0 is directly connected, Serial1/0

     134.1.0.0/24 is subnetted, 1 subnets

C       134.1.1.0 is directly connected, Ethernet0/0

     45.0.0.0/24 is subnetted, 1 subnets

D       45.1.1.0 [90/2195456] via 134.1.1.4, 01:28:10, Ethernet0/0

D    192.168.0.0/20 [90/2323456] via 134.1.1.4, 00:42:19, Ethernet0/0

 

----------------------------------华丽分割线------------------------------

R2配置:

R2#sh run

Building configuration...

 

Current configuration : 1323 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup

!

username lust privilege 15 password 0 cisco

!

interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1/0

 bandwidth 512

 ip address 23.1.1.2 255.255.255.0

 serial restart-delay 0

 clock rate 64000

!

interface Serial1/1

 ip address 12.1.1.2 255.255.255.0

 serial restart-delay 0

 clock rate 64000

!

router eigrp 100

 variance 3

 network 2.2.2.0 0.0.0.255

 network 12.1.1.0 0.0.0.255

 network 23.1.1.0 0.0.0.255

 no auto-summary

!

no ip http server

no ip http secure-server

!

control-plane

!

line con 0

 logging synchronous

line aux 0

line vty 0 4

 password cisco

 login

!

end

----------------------------------华丽分割线------------------------------

R2路由表

R2#sh ip ro

Gateway of last resort is 23.1.1.3 to network 3.0.0.0

 

     1.0.0.0/24 is subnetted, 1 subnets

D       1.1.1.0 [90/5665536] via 23.1.1.3, 01:08:00, Serial1/0

                [90/2297856] via 12.1.1.1, 01:08:00, Serial1/1

     2.0.0.0/24 is subnetted, 1 subnets

C       2.2.2.0 is directly connected, Loopback0

D*   3.0.0.0/8 [90/5639936] via 23.1.1.3, 01:08:00, Serial1/0

               [90/2323456] via 12.1.1.1, 01:08:00, Serial1/1

     4.0.0.0/24 is subnetted, 1 subnets

D       4.4.4.0 [90/5665536] via 23.1.1.3, 01:08:00, Serial1/0

                [90/2323456] via 12.1.1.1, 01:08:00, Serial1/1

     5.0.0.0/24 is subnetted, 1 subnets

D       5.5.5.0 [90/6177536] via 23.1.1.3, 01:08:00, Serial1/0

                [90/2835456] via 12.1.1.1, 01:08:00, Serial1/1

     23.0.0.0/24 is subnetted, 1 subnets

C       23.1.1.0 is directly connected, Serial1/0

     12.0.0.0/24 is subnetted, 1 subnets

C       12.1.1.0 is directly connected, Serial1/1

     134.1.0.0/24 is subnetted, 1 subnets

D       134.1.1.0 [90/5537536] via 23.1.1.3, 01:08:00, Serial1/0

                  [90/2195456] via 12.1.1.1, 01:08:00, Serial1/1

     45.0.0.0/24 is subnetted, 1 subnets

D       45.1.1.0 [90/6049536] via 23.1.1.3, 01:08:00, Serial1/0

                 [90/2707456] via 12.1.1.1, 01:08:00, Serial1/1

D    192.168.0.0/20 [90/6177536] via 23.1.1.3, 00:44:36, Serial1/0

                    [90/2835456] via 12.1.1.1, 00:44:36, Serial1/1

 ----------------------------------华丽分割线------------------------------

R3配置:

R3#sh run 

Building configuration...

 

Current configuration : 1232 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup

!

interface Loopback0

 ip address 3.3.3.3 255.0.0.0

!

interface Loopback100

 ip address 100.100.100.100 255.255.255.0

!

interface Ethernet0/0

 ip address dhcp

 full-duplex

!

interface Serial1/1

 ip address 23.1.1.3 255.255.255.0

 serial restart-delay 0

!

router eigrp 100

 network 3.0.0.0

 network 23.1.1.0 0.0.0.255

 network 134.1.1.0 0.0.0.255

 no auto-summary

!        

no ip http server

no ip http secure-server

!

ip default-network 3.0.0.0

!

control-plane

!

line con 0

 logging synchronous

line aux 0

line vty 0 4

!

end

 

----------------------------------华丽分割线------------------------------

R3路由表

R3#sh ip ro

Gateway of last resort is not set

 

     1.0.0.0/24 is subnetted, 1 subnets

D       1.1.1.0 [90/409600] via 134.1.1.1, 01:10:38, Ethernet0/0

     2.0.0.0/24 is subnetted, 1 subnets

D       2.2.2.0 [90/2297856] via 23.1.1.2, 01:10:38, Serial1/1

     100.0.0.0/24 is subnetted, 1 subnets

C       100.100.100.0 is directly connected, Loopback100

C*   3.0.0.0/8 is directly connected, Loopback0

     4.0.0.0/24 is subnetted, 1 subnets

D       4.4.4.0 [90/409600] via 134.1.1.4, 01:10:38, Ethernet0/0

     5.0.0.0/24 is subnetted, 1 subnets

D       5.5.5.0 [90/2323456] via 134.1.1.4, 01:10:38, Ethernet0/0

     23.0.0.0/24 is subnetted, 1 subnets

C       23.1.1.0 is directly connected, Serial1/1

     12.0.0.0/24 is subnetted, 1 subnets

D       12.1.1.0 [90/2195456] via 134.1.1.1, 01:10:38, Ethernet0/0

     134.1.0.0/24 is subnetted, 1 subnets

C       134.1.1.0 is directly connected, Ethernet0/0

     45.0.0.0/24 is subnetted, 1 subnets

D       45.1.1.0 [90/2195456] via 134.1.1.4, 01:10:38, Ethernet0/0

D    192.168.0.0/20 [90/2323456] via 134.1.1.4, 00:46:42, Ethernet0/0

 

 ----------------------------------华丽分割线------------------------------

R4配置:

R4#sh run

Building configuration...

 

Current configuration : 1421 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R4

!

boot-start-marker

boot-end-marker

!

no aaa new-model

memory-size iomem 5

!

ip cef

no ip domain lookup

no ip dhcp use vrf connected

!

ip dhcp pool dhcp

   network 134.1.1.0 255.255.255.0

!

  

interface Loopback0

 ip address 4.4.4.4 255.255.255.0

!

interface Ethernet0/0

 ip address 134.1.1.4 255.255.255.0

 ip nat inside

 ip virtual-reassembly

 full-duplex

!

interface Serial1/1

 ip address 45.1.1.4 255.255.255.0

 ip nat outside

 ip virtual-reassembly

 serial restart-delay 0

!

 

router eigrp 100

 network 4.4.4.0 0.0.0.255

 network 45.1.1.0 0.0.0.255

 network 134.1.1.0 0.0.0.255

 no auto-summary

!

no ip http server

no ip http secure-server

!

ip nat inside source static tcp 2.2.2.2 23 4.4.4.4 23 extendable

!

control-plane

!

line con 0

 logging synchronous

line aux 0

line vty 0 4

 password cisco

 login

!

end

 ----------------------------------华丽分割线------------------------------

R4路由表

R4#sh ip ro

 

Gateway of last resort is 134.1.1.2 to network 3.0.0.0

 

     1.0.0.0/24 is subnetted, 1 subnets

D       1.1.1.0 [90/409600] via 134.1.1.1, 01:34:11, Ethernet0/0

     2.0.0.0/24 is subnetted, 1 subnets

D       2.2.2.0 [90/2323456] via 134.1.1.2, 01:12:30, Ethernet0/0

                [90/2323456] via 134.1.1.1, 01:12:30, Ethernet0/0

D*   3.0.0.0/8 [90/409600] via 134.1.1.2, 01:24:01, Ethernet0/0

     4.0.0.0/24 is subnetted, 1 subnets

C       4.4.4.0 is directly connected, Loopback0

     5.0.0.0/24 is subnetted, 1 subnets

D       5.5.5.0 [90/2297856] via 45.1.1.5, 01:34:39, Serial1/1

     23.0.0.0/24 is subnetted, 1 subnets

D       23.1.1.0 [90/2195456] via 134.1.1.2, 01:13:38, Ethernet0/0

     12.0.0.0/24 is subnetted, 1 subnets

D       12.1.1.0 [90/2195456] via 134.1.1.1, 01:15:06, Ethernet0/0

     134.1.0.0/24 is subnetted, 1 subnets

C       134.1.1.0 is directly connected, Ethernet0/0

     45.0.0.0/24 is subnetted, 1 subnets

C       45.1.1.0 is directly connected, Serial1/1

D    192.168.0.0/20 [90/2297856] via 45.1.1.5, 00:48:34, Serial1/1

 ----------------------------------华丽分割线------------------------------

R5配置:

R2#sh run

Building configuration...

 

Current configuration : 1323 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup

!

username lust privilege 15 password 0 cisco

!

interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1/0

 bandwidth 512

 ip address 23.1.1.2 255.255.255.0

 serial restart-delay 0

 clock rate 64000

!

interface Serial1/1

 ip address 12.1.1.2 255.255.255.0

 serial restart-delay 0

 clock rate 64000

!

router eigrp 100

 variance 3

 network 2.2.2.0 0.0.0.255

 network 12.1.1.0 0.0.0.255

 network 23.1.1.0 0.0.0.255

 no auto-summary

!

no ip http server

no ip http secure-server

!

control-plane

!

line con 0

 logging synchronous

line aux 0

line vty 0 4

 password cisco

 login

!

!

end

 

----------------------------------华丽分割线------------------------------

R5路由表

R2#sh ip ro

Gateway of last resort is 23.1.1.3 to network 3.0.0.0

 

     1.0.0.0/24 is subnetted, 1 subnets

D       1.1.1.0 [90/5665536] via 23.1.1.3, 01:12:46, Serial1/0

                [90/2297856] via 12.1.1.1, 01:12:46, Serial1/1

     2.0.0.0/24 is subnetted, 1 subnets

C       2.2.2.0 is directly connected, Loopback0

D*   3.0.0.0/8 [90/5639936] via 23.1.1.3, 01:12:46, Serial1/0

               [90/2323456] via 12.1.1.1, 01:12:46, Serial1/1

     4.0.0.0/24 is subnetted, 1 subnets

D       4.4.4.0 [90/5665536] via 23.1.1.3, 01:12:46, Serial1/0

                [90/2323456] via 12.1.1.1, 01:12:46, Serial1/1

     5.0.0.0/24 is subnetted, 1 subnets

D       5.5.5.0 [90/6177536] via 23.1.1.3, 01:12:47, Serial1/0

                [90/2835456] via 12.1.1.1, 01:12:47, Serial1/1

     23.0.0.0/24 is subnetted, 1 subnets

C       23.1.1.0 is directly connected, Serial1/0

     12.0.0.0/24 is subnetted, 1 subnets

C       12.1.1.0 is directly connected, Serial1/1

     134.1.0.0/24 is subnetted, 1 subnets

D       134.1.1.0 [90/5537536] via 23.1.1.3, 01:12:48, Serial1/0

                  [90/2195456] via 12.1.1.1, 01:12:48, Serial1/1

     45.0.0.0/24 is subnetted, 1 subnets

D       45.1.1.0 [90/6049536] via 23.1.1.3, 01:12:48, Serial1/0

                 [90/2707456] via 12.1.1.1, 01:12:48, Serial1/1

D    192.168.0.0/20 [90/6177536] via 23.1.1.3, 00:49:23, Serial1/0

                    [90/2835456] via 12.1.1.1, 00:49:23, Serial1/1

 


本文转自lustlost 51CTO博客,原文链接:http://blog.51cto.com/lustlost/849391,如需转载请自行联系原作者

相关实践学习
部署高可用架构
本场景主要介绍如何使用云服务器ECS、负载均衡SLB、云数据库RDS和数据传输服务产品来部署多可用区高可用架构。
负载均衡入门与产品使用指南
负载均衡(Server Load Balancer)是对多台云服务器进行流量分发的负载均衡服务,可以通过流量分发扩展应用系统对外的服务能力,通过消除单点故障提升应用系统的可用性。 本课程主要介绍负载均衡的相关技术以及阿里云负载均衡产品的使用方法。
相关文章
|
8月前
|
存储 负载均衡 网络协议
企业实战(13)LVS负载均衡DR(直接路由)模式实战详解(二)
企业实战(13)LVS负载均衡DR(直接路由)模式实战详解(二)
133 0
|
27天前
|
Kubernetes 负载均衡 应用服务中间件
深入理解 Kubernetes Ingress:路由流量、负载均衡和安全性配置
深入理解 Kubernetes Ingress:路由流量、负载均衡和安全性配置
|
28天前
VRRP配置案例(路由走向分析,端口切换)
VRRP配置案例(路由走向分析,端口切换)
14 0
|
28天前
|
Android开发
Android 修改盒子路由方式 Static / DHCP
Android 修改盒子路由方式 Static / DHCP
20 2
|
28天前
|
网络协议 网络架构
DHCP中继实验
DHCP中继实验
|
28天前
|
网络协议
DHCP实验-动态主机配置协议
DHCP实验-动态主机配置协议
|
28天前
|
网络协议
第二轮学习笔记: 扫描工具 -- nmap端口扫描
第二轮学习笔记: 扫描工具 -- nmap端口扫描
28 0
|
7月前
|
开发工具
debian-dhcp实验(傻瓜教程)
debian-dhcp实验(傻瓜教程)
36 0
|
8月前
|
存储 网络协议 分布式数据库
网络名词术语解析 | 路由、交换机、集线器、半/全双工、DNS、LAN、WAN、端口、MTU
网络名词术语解析 | 路由、交换机、集线器、半/全双工、DNS、LAN、WAN、端口、MTU
166 0
|
9月前
|
存储 负载均衡 网络协议
LVS负载均衡群集—DR直接路由
LVS负载均衡群集—DR直接路由
69 0