POJ2299 Ultra-QuickSort 【树阵】+【hash】

简介:
Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 39529   Accepted: 14250

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,
Ultra-QuickSort produces the output 
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

注意结果要用long long存储。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 500002
using std::sort;

int tree[maxn], ori[maxn], hash[maxn];
long long ans;

int getHash(int val, int n)
{
	int left = 0, right = n - 1, mid;
	while(left <= right){
		mid = (left + right) >> 1;
		if(val < hash[mid]) right = mid - 1;
		else if(val > hash[mid]) left = mid + 1;
		else return mid + 1;
	}
}

int lowBit(int pos){ return pos & (-pos); }

int getSum(int pos)
{
	int sum = 0;
	while(pos > 0){
		sum += tree[pos];
		pos -= lowBit(pos);
	}
	return sum;
}

void update(int pos, int n)
{
	ans += (pos - 1 - getSum(pos - 1));
	while(pos <= n){
		++tree[pos];
		pos += lowBit(pos);
	}
}


int main()
{
	int n, i;
	while(scanf("%d", &n), n){
		for(i = 0; i < n; ++i){
			scanf("%d", ori + i);
			hash[i] = ori[i];
		}
		
		sort(hash, hash + n);		
		for(i = 0; i < n; ++i)
			ori[i] = getHash(ori[i], n);			
		memset(tree, 0, sizeof(tree));
		
		ans = 0;
		for(i = 0; i < n; ++i) update(ori[i], n);
		printf("%lld\n", ans);
	}
	
	return 0;
}


版权声明:本文博客原创文章,博客,未经同意,不得转载。





本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4649407.html,如需转载请自行联系原作者


相关文章
|
人工智能 vr&ar
Atcoder--Candy Distribution II--前缀和+map
题目描述 There are N boxes arranged in a row from left to right. The i-th box from the left contains Ai candies. You will take out the candies from some consecutive boxes and distribute them evenly to M children. Such being the case, find the number of the pairs (l,r) that satisfy the following:
77 0
|
人工智能 Java
[LeetCode]--73. Set Matrix Zeroes
Given a m x n matrix, if an element is 0, set its entire row and column to 0. Do it in place. click to show follow up. Follow up: Did you use extra space? A straight forward solution us
959 0
[LeetCode]--71. Simplify Path
Given an absolute path for a file (Unix-style), simplify it. For example, path = “/home/”, =&gt; “/home” path = “/a/./b/../../c/”, =&gt; “/c” click to show corner cases. Corner Cases:
1035 0
|
算法
[LeetCode]--60. Permutation Sequence
The set [1,2,3,…,n] contains a total of n! unique permutations. By listing and labeling all of the permutations in order, We get the following sequence (ie, for n = 3): 1."123" 2."132" 3
1059 1
|
算法
[LeetCode]--39. Combination Sum
Given a set of candidate numbers (C) and a target number (T), find all unique combinations in C where the candidate numbers sums to T. The same repeated number may be chosen from C unlimit
998 0
[LeetCode]--40. Combination Sum II
Given a collection of candidate numbers (C) and a target number (T), find all unique combinations in C where the candidate numbers sums to T. Each number in C may only be used once in the
1266 0
[LeetCode]--49. Group Anagrams
Given an array of strings, group anagrams together. For example, given: [“eat”, “tea”, “tan”, “ate”, “nat”, “bat”], Return: [ ["ate", "eat","tea"], ["nat","tan"], ["bat"] ] Note
1088 0
[LeetCode]--383. Ransom Note

Given
 an 
arbitrary
 ransom
 note
 string 
and 
another 
string 
containing 
letters from
 all 
the 
magazines,
 write 
a 
function 
that 
will 
return 
true 
if 
the 
ransom 
 note 
can
1306 0