Elcipse Plugin for Debugging ArcObjects

简介:
 ESRI ArcGIS Engine和ArcGIS Server虽然都支持基于Java平台的开发,但都存在一个问题——调试困难,因为ArcGIS Server ADF是用Java重写的,所以不存在调试的问题,但是一旦涉及到调用底层COM对象,无论是ArcEngine还是AGS,IDE自带的调试工具就无能为力了,调试窗口显示的都是这些对象代理的细节,非ArcObjects的状态,对于ArcGIS的研发工程师来说,重要的是AO、ADF设计框架与开发,非开发语言,这就造成了我最初从Java平台转向.Net平台,方便学习:)

    引用一张ESRI网站上的截图,也是过去我们经常碰到的:

    ESRI应该早就意识到这个问题,现在终于提供了一个Eclipse插件,方便基于Eclipse IDE环境开发的工程师调试arcengine和ags,推广在非windows平台上的系统开发和应用,至于是否好用还不知道,希望这是一个好的起点,越做越完善:

    现在就开始添加插件:

    1.打开Eclipse--帮助--软件更新--搜索和安装


    2.添加新的远程站点: http://downloads.esri.com/EDN/java/plugins/eclipse ,命名Eclipse_Java_Plugins


    3.勾选Eclipse_Java_Plugins,完成


    4.执行更新


    5.在搜索结果中选择"ArcGIS Debug 9.2.0"


    6.接受许可协议中的条款


    7.确认按装信息


    8.安装


本文转自Flyingis博客园博客,原文链接:http://www.cnblogs.com/flyingis/archive/2008/03/13/1103343.html,如需转载请自行联系原作者

相关文章
|
9月前
bug:The following dependencies are imported but could not be resolved lib-flexibleflexible
bug:The following dependencies are imported but could not be resolved lib-flexibleflexible
635 0
|
9月前
解决 This is probably not a problem with npm. There is likely additional logging output above.
解决 This is probably not a problem with npm. There is likely additional logging output above.
253 1
|
11月前
|
Linux 开发者 Windows
Flutter报错Building with plugins requires symlink support的解决方法
Flutter报错Building with plugins requires symlink support的解决方法
|
11月前
Plugin ‘maven-clean-plugin:3.1.0‘ not found
Plugin ‘maven-clean-plugin:3.1.0‘ not found
146 0
|
Java Scala
sbt.internal.inc.CompileFailed: Error compiling the sbt component ‘compiler-interface-2.11.8-61.0‘
IDEA 的 JDK 和 Scala 版本对应不上。 使用 Scala12.1.8配上 JDK8
314 0
No matching configuration of project :libusb was found.
No matching configuration of project :libusb was found.
470 0
mvn Failed during checkstyle execution: There are errors reported by Checkstyle 6.2
mvn Failed during checkstyle execution: There are errors reported by Checkstyle 6.2
98 0
|
Java
No compiler is provided in this environment. Perhaps you are running on a JRE
No compiler is provided in this environment. Perhaps you are running on a JRE
106 0
CMake 3.7.2 or higher is required. You are running version 2.8.12.2
CMake 3.7.2 or higher is required. You are running version 2.8.12.2
225 0
|
Java 编译器 Maven
maven项目build时出现 No compiler is provided in this environment.错误
maven项目build时出现 No compiler is provided in this environment.错误
maven项目build时出现 No compiler is provided in this environment.错误

热门文章

最新文章