数论E - Biorhythms(中国剩余定理,一水)

简介:
E - Biorhythms
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit   Status

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

刚接触中国剩余定理,感觉好奇妙啊。x = ( M1*a1*c1 + M2*a2*c2 + M3*a3*c3 。。

)% M ;

M = a1 * a2 *a3.......an ;  要求ai必须互素,不互素的话不能使用中国剩余定理

Mi = M / ai ;    Mi*ai ≡ 1 (mod mi) ;

承认解释不了原因。。。

。。 求大牛解释。

。。



#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
void gcd(int a,int b,int &d,int &x,int &y)
{
    if(b == 0)
    {
        d = a ;
        x = 1 ;
        y = 0 ;
    }
    else
    {
        gcd(b,a%b,d,y,x);
        x = -x ; y = -y ;
        y += a/b*x ;
    }
    return ;
}
int main()
{
    int temp = 0 , i , a , b , c , num , d , x , y , M , ans ;
    while(scanf("%d %d %d %d", &a, &b, &c, &num)!=EOF)
    {
        if(a + b + c + num == -4)
            break;
        a %= 23 ; b %= 28 ; c %= 33 ;
        ans = 0 ;
        M = 23*28*33 ;
        gcd(M/23,23,d,x,y);
        x = (x%23+23)%23 ;
        ans += M/23*x*a ;
        gcd(M/28,28,d,x,y);
        x = (x%28+28)%28 ;
        ans += M/28*x*b ;
        gcd(M/33,33,d,x,y);
        x = (x%33+33)%33;
        ans += M/33*x*c ;
        ans %= M ;
        if(ans-num <= 0)
            ans += M ;
        printf("Case %d: the next triple peak occurs in %d days.\n", ++temp, ans-num);
    }
    return 0;
}






本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5385613.html,如需转载请自行联系原作者

相关文章
|
7月前
|
算法 安全 Java
非启发式算法——中国剩余定理
非启发式算法——中国剩余定理
132 0
|
7月前
D - 11(逆元好题)
D - 11(逆元好题)
|
算法 C++
朝题夕解之数论
朝题夕解之数论
94 0
朝题夕解之数论
|
算法
数学知识:中国剩余定理
复习acwing算法基础课的内容,本篇为讲解数学知识:中国剩余定理,关于时间复杂度:目前博主不太会计算,先鸽了,日后一定补上。
214 0
数学知识:中国剩余定理
[解题报告]《算法零基础100讲》(第9讲) 算术基本定理
[解题报告]《算法零基础100讲》(第9讲) 算术基本定理
[解题报告]《算法零基础100讲》(第9讲) 算术基本定理
[Codeforces] 1557 C Moamen and XOR(组合数学)
题意: 用 < 2k的数填充到长度为n的数组中,要使得数组中所有数& >= ^,问方案数 显然,当k == 1的时候,答案为1,只有当所有的数全为1的情况才可以满足题意 对于其他的情况{ 用小于2k的数进行填充,那么说明填充的数字的二进制位数最多可以有k kk位, 从数的个数的角度来说,奇数个1^ 之后的结果是1,偶数个1^ 之后的结果是0,而对于0来讲,不管多少个0,^起来结果都是0 只要有一个0,那么说这一位上&之后就是0,而为了让^为0,那么只能够选择偶数个1 如果某一位上&为1,那么^为1的情况需要讨论n的奇偶性
128 0
|
算法
POJ 3154 Graveyard【多解,数论,贪心】
Graveyard Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 1707   Accepted: 860   Special Judge Description Prog...
1253 0