2014年多校联合赛第二场1011

简介: ZCC Loves Codefires Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 0    Accepted Submi...

ZCC Loves Codefires

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
 
 
Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137". It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and 
immediately became his fan. But why? Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of 
time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. 
He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the 
achievement in the field of Data Structures. After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible. What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if
Memset137 solves the
problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time. Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program 
to calculate the minimal score he will lose.(that is, the sum of Ki*Ti).
 

Input
 
 
The first line contains an integer N(1≤N≤10^5), the number of problem in the round. The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem. The last line contains N integers Ki(1≤Ki≤10^4), as was described.
 

Output
 
 
One integer L, the minimal score he will lose.
 

Sample Input
 
 
3 10 10 20 1 2 3
 

Sample Output
 
 
150
Hint
Memset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets 
AK at the end of the 40th second. L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150.
题意:做每道题都有时间和权值,总时间和杭电平时比赛做题时间统计一样。但是遇到一个比较奇葩的问题,数据类型
不知道为什么不能用double,是能用long long!希望有大神看到给指点一下!
AC代码:
#include<cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
struct A
{   int x,y;
    double z;
};
int cmp(A a,A b)
{
    return a.z<b.z;
}
A a[110000];
int main()
{
    int n,i;
    scanf("%d",&n);
    memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
            scanf("%d",&a[i].x);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i].y);
            a[i].z=a[i].x*1.0/a[i].y;
        }
        sort(a,a+n,cmp);
        long long int num=0,sum=0;
        for(i=0;i<n;i++)
        {
            num+=a[i].x;
            sum+=num*a[i].y;
        }
        printf("%I64d\n",sum);
return 0;
}

错误代码:
<pre name="code" class="html">#include<cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
struct A
{
    double x,y,z;
};
int cmp(A a,A b)
{
    return a.z<b.z;
}
A a[110000];
int main()
{
    int n,i;
    scanf("%d",&n);
    memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
            scanf("%lf",&a[i].x);
        for(i=0;i<n;i++)
        {
            scanf("%lf",&a[i].y);
            a[i].z=a[i].x/a[i].y;
        }
        sort(a,a+n,cmp);
        double num=0,sum=0;
        for(i=0;i<n;i++)
        {
            num+=a[i].x;
            sum+=num*a[i].y;
        }
        printf("%.0lf\n",sum);
return 0;
}




 
目录
相关文章
|
定位技术 Go
第 45 届国际大学生程序设计竞赛(ICPC)亚洲区域赛(银川),签到题5题
第 45 届国际大学生程序设计竞赛(ICPC)亚洲区域赛(银川),签到题5题
91 0
|
1月前
|
数据采集 人工智能 算法
近五千支队伍决战AI之巅, AFAC2024金融智能创新大赛在2024 Inclusion · 外滩大会完美收官
自从2022年12月ChatGPT上线以来,全球掀起了一场你追我赶的AI竞赛,不少国家都在全力以赴,抢占制高点。
|
2月前
|
机器学习/深度学习 人工智能 Cloud Native
2024 天池云原生编程挑战赛决赛名单出炉,冠军来自中山大学、昆仑数智战队
2024 天池云原生编程挑战赛由阿里云主办,云原生应用平台、天池以及市场营销部联合承办,本届大赛成功吸引了超过 20500 支队伍积极参与,参赛者来自 10 多个国家和地区,大赛规模创下历史新高。
|
Cloud Native 中间件 Serverless
2023 云原生编程挑战赛收官:1.8 万人报名,冠军花落北京邮电大学、电子科技大学、旷识科技
2023 云原生编程挑战赛收官:1.8 万人报名,冠军花落北京邮电大学、电子科技大学、旷识科技
2023 云原生编程挑战赛收官:1.8 万人报名,冠军花落北京邮电大学、电子科技大学、旷识科技
|
Cloud Native 安全 前端开发
2023 云原生编程挑战赛入围决赛答辩名单公布
2023 云原生编程挑战赛入围决赛答辩名单公布
|
算法
算法|华为精英挑战赛赛前预备
算法|华为精英挑战赛赛前预备
102 0
时隔4年再夺金奖!北大斩获「编程奥林匹克」亚军,刷新队史最高排名
时隔4年再夺金奖!北大斩获「编程奥林匹克」亚军,刷新队史最高排名
174 0
|
算法
2021-2022年度第三届全国大学生算法设计与编程挑战赛(秋季赛)热身赛 B.这是一道大水题(树状数组)
2021-2022年度第三届全国大学生算法设计与编程挑战赛(秋季赛)热身赛 B.这是一道大水题(树状数组)
160 0
2021-2022年度第三届全国大学生算法设计与编程挑战赛(秋季赛)热身赛 B.这是一道大水题(树状数组)
第八届“互联网+”大赛阿里云7大方向 32道命题邀你来创
今年互联网+大赛企业赛道发布了很多题目,这些题目都是阿里等大公司出题,很多题目非常适合我们组织研究生参赛。因为我们研究生和校企合作体量都很大。这方面的成绩也是支撑我们学院研究生培养质量特别是专业学位培养成果的重要体现。请各位老师抽空看看赛题,积极发动学生组队参加。
524 0
第八届“互联网+”大赛阿里云7大方向 32道命题邀你来创
|
安全 API UED
哈佛校友Salesforce黑客马拉松赛夺冠,获百万美元大奖
在Salesforce.com本周举办的黑客马拉松比赛上,哈佛大学校友托姆·吉姆(Thom Kim)和约瑟夫·图利安(Joseph Turian)联手开发的移动应用Upshot最终夺冠,捧走了高达100万美元的奖金。
293 0
哈佛校友Salesforce黑客马拉松赛夺冠,获百万美元大奖