poj 1328 【Radar Installation】【几何转化、区间覆盖】

简介: 点击打开题目 Radar Installation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 54970   Accepted: 12381 Descrip...

点击打开题目

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 54970   Accepted: 12381

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

题目翻译:给出两个数字n和d,n代表n个P点,d代表圆的半径,然后下面n行,每行一组坐标(x,y),分别代表所有的P点,

求:在x坐标轴上,至少要画几个以d为半径的圆,才能使P点均在圆内。


解题思路:分别以P点为圆心,d为半径画圆,圆分别会在x轴上截取相应的线段,只要线段内有圆心,则即可覆盖P点,因此问题

便转化为求X轴上共有多少独立区间!


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<math.h>
using namespace std;
struct A{
	double zuo,you;
};
int cmp(A a,A b){
	return a.zuo<b.zuo;
}
int main(){
	int t=1,n,i,r,x,y,yes;
	A a[1200];
	while(scanf("%d%d",&n,&r)&&!(n==0&&r==0)){
        yes=0;
		for(i=1;i<=n;i++){
			scanf("%d%d",&x,&y);
			if(r<y) yes=1;
			double num=sqrt((double)(r*r-y*y));
			a[i].zuo=double(x-num);
			a[i].you=double(x+num);
		}
		if(yes){printf("Case %d: -1\n",t++);continue;}
		sort(a+1,a+n+1,cmp);
		double k=a[1].you;
		int count=1;
		for(i=2;i<=n;i++){
			if(a[i].zuo>k){
				k=a[i].you;
				count++;
			}
			else{
				if(a[i].you<k)
					k=a[i].you;
			}
		}
		printf("Case %d: %d\n",t++,count);
	}
	return 0;
}


目录
相关文章
一看就会R语言绘制限制性立方样条(Restricted cubic spline,RCS)
最近在研究怎么处理论文数据,各种分析软件都有使用,比如:SPSS、Origin、stata16、medcalc和R语言都有些研究,其中除R语言外都是收费的。不过经过一番功夫,我这边有SPSS、stata16、Origin和medcalc的破解版,有需要的可以关注我的公众号,私聊我来获取,我将给你一个百度网盘下载地址。
673 0
|
6月前
|
C++
D. Directed Roads(拓扑排序+组合计算)
D. Directed Roads(拓扑排序+组合计算)
|
人工智能 数据可视化
跟SCI学umap图| ggplot2 绘制umap图,坐标位置 ,颜色 ,大小还不是你说了算
跟SCI学umap图| ggplot2 绘制umap图,坐标位置 ,颜色 ,大小还不是你说了算
1075 1
2021杭电多校第八场 HDU7063-Square Card(求两圆相交面积)
2021杭电多校第八场 HDU7063-Square Card(求两圆相交面积)
72 0
2021杭电多校第八场 HDU7063-Square Card(求两圆相交面积)
POJ1269 Intersecting Lines(两直线关系)
POJ1269 Intersecting Lines(两直线关系)
58 0
luoguP2205 [USACO13JAN]Painting the Fence S(差分 扫描线思想)
luoguP2205 [USACO13JAN]Painting the Fence S(差分 扫描线思想)
57 0
|
机器学习/深度学习
HDOJ(HDU) 2524 矩形A + B(推导公式、)
HDOJ(HDU) 2524 矩形A + B(推导公式、)
98 0
HDOJ(HDU) 2524 矩形A + B(推导公式、)