Problem Description
Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball every www seconds. However, the machine has some flaws, every time after xxx seconds of process the machine has to turn off for yyy seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it's off, the machine will pop out no ball before the machine restart.
Now, at the 000 second, the machine opens for the first time. Victor wants to know when the nnn-th ball will be popped out. Could you tell him?
Input
The input contains several test cases, at most 100100100 cases.
Each line has four integers xxx, yyy, www and nnn. Their meanings are shown above。
1≤x,y,w,n≤1001\leq x,y,w,n\leq 1001≤x,y,w,n≤100.
Output
For each test case, you should output a line contains a number indicates the time when the nnn-th ball will be popped out.
Sample Input
2 3 3 3
98 76 54 32
10 9 8 100
Sample Output
10
2664
939
题目大意:Victor有一个机器,这个机器每次开启的瞬间会弹出一个小球,之后每隔www秒会弹出一个小球。因为机器不是很完善,该机器每开启xxx秒就得关闭yyy秒进行调整,在机器关闭的瞬间可能会有小球弹出,关闭之后一直到下一次开启之前都不会有小球弹出。
0时刻,机器第一次开启,Victor想要知道第nnn个小球弹出的时刻,你能够告诉他吗?
解题思路:就是自己推一下就行了。。。
直接上代码
#include <iostream>
using namespace std;
int main()
{
int x, y, w, n;
while(cin>>x>>y>>w>>n)
{
n -= 1;
int ans, tmp1, tmp2;
if(w > x)
ans = (x+y)*n;
else
{
tmp1 = n % ((int)(x/w)+1);
tmp2 = n / (x/w+1);
ans = tmp2*(x+y)+w*tmp1;
}
cout<<ans<<endl;
}
return 0;
}