马的遍历
题目描述
有一个 $n \times m$ 的棋盘,在某个点 $(x, y)$ 上有一个马,要求你计算出马到达棋盘上任意一个点最少要走几步。
输入格式
输入只有一行四个整数,分别为 $n, m, x, y$。
输出格式
一个 $n \times m$ 的矩阵,代表马到达某个点最少要走几步(不能到达则输出 $-1$)。
样例 #1
样例输入 #1
3 3 1 1
样例输出 #1
0 3 2
3 -1 1
2 1 4
提示
数据规模与约定
对于全部的测试点,保证 $1 \leq x \leq n \leq 400$,$1 \leq y \leq m \leq 400$。
思路
- 马走“日”
- 输出格式:域宽为5,左对齐
- 注意判断是否越界
AC代码
#include <iostream>
#include <queue>
#include <cstring>
#define AUTHOR "HEX9CF"
using namespace std;
const int maxn = 405;
const int sun[8][2] = {
-2, 1, -2, -1, -1, 2, -1, -2, 2, 1, 2, -1, 1, 2, 1, -2};
int n, m, x, y;
bool vis[maxn][maxn];
int stp[maxn][maxn];
queue<pair<int, int>> q;
void bfs(int x, int y)
{
vis[x][y] = 1;
stp[x][y] = 0;
q.push(make_pair(x, y));
while (!q.empty())
{
pair<int, int> f = q.front();
q.pop();
for (int i = 0; i < 8; i++)
{
int xx = f.first + sun[i][0];
int yy = f.second + sun[i][1];
if (xx > 0 && xx <= n && yy > 0 && yy <= m && !vis[xx][yy])
{
vis[xx][yy] = 1;
q.push(make_pair(xx, yy));
stp[xx][yy] = stp[f.first][f.second] + 1;
}
}
}
}
int main()
{
memset(vis, 0, sizeof(vis));
memset(stp, -1, sizeof(stp));
cin >> n >> m >> x >> y;
stp[x][y] = 0;
vis[x][y] = true;
q.push(make_pair(x, y));
bfs(x, y);
for (int i = 1; i <= n; i++)
{
for (int j = 1; j <= m; j++)
{
printf("%-5d", stp[i][j]);
}
putchar('\n');
}
return 0;
}