连通块中点的数量
给定一个包含 n 个点(编号为 1∼n)的无向图,初始时图中没有边。
现在要进行 m 个操作,操作共有三种:
C a b,在点 a 和点 b 之间连一条边,a 和 b 可能相等;
Q1 a b,询问点 a 和点 b 是否在同一个连通块中,a 和 b 可能相等;
Q2 a,询问点 a 所在连通块中点的数量;
输入格式
第一行输入整数 n 和 m。
接下来 m 行,每行包含一个操作指令,指令为 C a b,Q1 a b 或 Q2 a 中的一种。
输出格式
对于每个询问指令 Q1 a b,如果 a 和 b 在同一个连通块中,则输出 Yes,否则输出 No。
对于每个询问指令 Q2 a,输出一个整数表示点 a 所在连通块中点的数量
每个结果占一行。
数据范围
1≤n,m≤105
输入样例:
5 5
C 1 2
Q1 1 2
Q2 1
C 2 5
Q2 5
输出样例:
Yes
2
3
讲解
该题是并查集的应用,乍看像图论,其实是并查集
每一个连通块其实都是一个集合。
- 对于连边操作,其实就是集合间的合并。
- 对于查询是否在同一连通块,也就是集合的询问操作。
- 对于查询连通块中点的数量,也就是查询集合的大小。
因此,我们这题直接用并查集模板就可以完成了。
只是要附加一个s数组记录一下每个集合的大小,在合并的时候加上即可。
提交代码
#include<bits/stdc++.h> using namespace std; int n, m; const int N = 100010; int p[N], s[N]; int find(int x) { if (x != p[x]) p[x] = find(p[x]); return p[x]; } int main() { scanf ("%d%d", &n, &m); for (int i = 1; i <= n; i++) { p[i] = i; s[i] = 1; } while (m --) { char op[5]; int a, b; scanf ("%s", op); if (op[0] == 'C') { scanf ("%d%d", &a, &b); if (find(a) == find(b)) continue; s[find(b)] += s[find(a)]; p[find(a)] = find(b); } else if (op[1] == '1') { scanf ("%d%d", &a, &b); find(a) == find(b) ? puts("Yes") : puts("No"); } else { scanf ("%d", &a); printf("%d\n", s[find(a)]); } } return 0; }
下面是一个并查集的题目:
合并集合
一共有 n 个数,编号是 1∼n,最开始每个数各自在一个集合中。
现在要进行 m 个操作,操作共有两种:
M a b,将编号为 a 和 b 的两个数所在的集合合并,如果两个数已经在同一个集合中,则忽略这个操作;
Q a b,询问编号为 a 和 b 的两个数是否在同一个集合中;
输入格式
第一行输入整数 n 和 m。
接下来 m 行,每行包含一个操作指令,指令为 M a b 或 Q a b 中的一种。
输出格式
对于每个询问指令 Q a b,都要输出一个结果,如果 a 和 b 在同一集合内,则输出 Yes,否则输出 No。
每个结果占一行。
数据范围
1≤n,m≤105
输入样例:
4 5
M 1 2
M 3 4
Q 1 2
Q 1 3
Q 3 4
输出样例:
Yes
No
Yes
提交代码
#include<iostream> using namespace std; const int N = 100010; int n, m; int p[N]; int find(int x) // 找到x的祖先节点 { if (p[x] != x) p[x] = find(p[x]); return p[x]; } int main() { scanf("%d %d", &n, &m); for (int i = 1; i <= n; ++i) p[i] = i; while (m--) { char op; int a, b; scanf (" %c%d%d", &op, &a, &b); if (op == 'M') p[find(a)] = find(b); // 让a的祖先节点指向b的祖先节点 else { if (find(a) == find(b)) puts("Yes"); else puts("No"); } } return 0; }
import java.io.*; public class Main { static int N = 100010; static int n, m; static int [] p = new int [N]; static int find(int x) { if (p[x] != x) p[x] = find(p[x]); return p[x]; } public static void main(String[] args) throws IOException { BufferedReader reader = new BufferedReader(new InputStreamReader (System.in)); String [] str = reader.readLine().split(" "); n = Integer.parseInt(str[0]); m = Integer.parseInt(str[1]); for (int i = 1; i <= n; ++ i) p[i] = i; while (m -- > 0) { String op; int a, b; str = reader.readLine().split(" "); op = str[0]; a = Integer.parseInt(str[1]); b = Integer.parseInt(str[2]); if (op.equals("M")) p[find(a)] = find(b); else { if (find(a) == find(b)) System.out.println("Yes"); else System.out.println("No"); } } } }