【PAT甲级 - C++题解】1032 Sharing

简介: 【PAT甲级 - C++题解】1032 Sharing

1032 Sharing


To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.


ca0e47f6c1f04dec81e5859c47ae0300.jpg


Figure 1


You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).


Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.


Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.


Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1


题意

给定两个链表的结点信息,每个链表中存储的是一个单词,需要找出两个单词中共同后缀的起始地址,即找到两个链表的第一个共同结点的地址,如果没有共同后缀则输出 -1 。


第一行输入的是两个链表的起始节点的地址以及结点的总数量 n ,下面 n 行输入每个结点的地址、数据和下一个结点的地址,其中 -1 表示 NULL 。


思路

具体思路如下:


1.先用数组将链表中结点的地址和数据存储起来。

2.用一个 bool 数组 st 来标记链表 1 中所有结点为 true 。

3.从头遍历链表 2 中的结点,只要出现第一个在 st 中标记为 true 的结点,则直接输出。

4.如果没有找到共同结点,则输出 -1 。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 100010;
int h1, h2, n, ne[N];
char e[N];
bool st[N];
int main()
{
    //输入每个结点的信息
    scanf("%d%d%d", &h1, &h2, &n);
    for (int i = 0; i < n; i++)
    {
        int address, next;
        char c;
        scanf("%d %c %d", &address, &c, &next);
        e[address] = c, ne[address] = next;
    }
    //标记链表1中的结点
    for (int i = h1; i != -1; i = ne[i])
        st[i] = true;
    //输出链表2中第一个与链表1共同的结点
    for (int i = h2; i != -1; i = ne[i])
        if (st[i])
        {
            printf("%05d\n", i);
            return 0;
        }
    puts("-1"); //不存在则输出-1
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
40 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
62 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
55 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
54 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
64 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
59 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
109 0
|
存储 定位技术 C++
【PAT甲级 - C++题解】1091 Acute Stroke
【PAT甲级 - C++题解】1091 Acute Stroke
38 0
|
存储 人工智能 C++
【PAT甲级 - C++题解】1085 Perfect Sequence
【PAT甲级 - C++题解】1085 Perfect Sequence
55 0
|
C++
【PAT甲级 - C++题解】1046 Shortest Distance
【PAT甲级 - C++题解】1046 Shortest Distance
53 0