【PAT甲级 - C++题解】1107 Social Clusters

简介: 【PAT甲级 - C++题解】1107 Social Clusters

1107 Social Clusters

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.


Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].


Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.


Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1


题意

给定社交网络中所有人的兴趣爱好,请你找到所有社会群集。


输入第一行是人数 n ,接下来的 n 行输入编号从 1~n 所有人的爱好。


社会群集判断标准:只要两个人有共同爱好,就属于同一社会群集,比如编号为 3 和 5 的人有共同爱好,3 和 7 的人也有共同爱好,则 3 、5 和 7 都属于同一社会群集。


思路

具体思路如下:

  1. 输入每个人的爱好,用一个数组 h 来存储每个爱好含有哪些人。
  2. 初始化并查集,然后将每个爱好中存储的人进行集合合并。
  3. 统计每个集合的人数并进行降序排序,然后统计集合的个数。
  4. 输出统计结果,注意行末不能有空格。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 1010;
int p[N], cnt[N];
vector<int> h[N];
//并查集查找模板
int find(int x)
{
    if (p[x] != x) p[x] = find(p[x]);
    return p[x];
}
int main()
{
    int n, k;
    cin >> n;
    //先整理每个爱好有哪些人
    for (int i = 0; i < n; i++)
    {
        scanf("%d:", &k);
        while (k--)
        {
            int x;
            cin >> x;
            h[x].push_back(i);
        }
    }
    //初始化并查集
    for (int i = 0; i < n; i++)    p[i] = i;
    //对每个爱好里的人进行集合合并
    for (int i = 1; i <= 1000; i++)
        for (int j = 1; j < h[i].size(); j++)
        {
            int a = h[i][0], b = h[i][j];
            a = find(a), b = find(b);
            p[a] = b;
        }
    //统计每个集合人数个数并进行降序排序
    for (int i = 0; i < n; i++)    cnt[find(i)]++;
    sort(cnt, cnt + n, greater<int>());
    //计算集合个数
    int res = 0;
    while (cnt[res]) res++;
    //输出统计结果
    cout << res << endl << cnt[0];
    for (int i = 1; i < res; i++)  cout << " " << cnt[i];
    cout << endl;
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
76 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
107 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
95 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
95 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
85 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
90 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
154 0
|
存储 定位技术 C++
【PAT甲级 - C++题解】1091 Acute Stroke
【PAT甲级 - C++题解】1091 Acute Stroke
67 0
|
存储 人工智能 C++
【PAT甲级 - C++题解】1085 Perfect Sequence
【PAT甲级 - C++题解】1085 Perfect Sequence
85 0
|
C++
【PAT甲级 - C++题解】1046 Shortest Distance
【PAT甲级 - C++题解】1046 Shortest Distance
77 0