【PAT甲级 - C++题解】1020 Tree Traversals

简介: 【PAT甲级 - C++题解】1020 Tree Traversals

1020 Tree Traversals


Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:


For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
• 1
• 2
• 3

Sample Output:

4 1 6 3 5 7 2

题意


第一行包含整数 N ,表示二叉树的节点数。


第二行包含 N  个整数,表示二叉树的后序遍历。


第三行包含 N  个整数,表示二叉树的中序遍历。


输出一行 N 个整数,表示二叉树的层序遍历。


思路

  1. 由于题目给定每个结点的值都不同,所以可以用哈希表存储每个结点在中序数组中的下标,方便后续使用。
  2. 通过下标构建二叉树(其中 k-1-il 表示左子树结点个数):


443492e50bd94524bcbcae9245095e98.png


  1. 通过 bfs 进行层次遍历,并输出最终结果。

代码

#include<bits/stdc++.h>
using namespace std;
const int N = 40;
int n;
int posorder[N], inorder[N];
unordered_map<int, int> l, r, pos;
int q[N];
//构建树
int build(int il, int ir, int pl, int pr)
{
    int root = posorder[pr];  //获得根结点
    int k = pos[root];    //获得该结点在中序数组中的下标
    if (il < k)   l[root] = build(il, k - 1, pl, pl + (k - 1 - il));        //递归左子树
    if (k < ir)   r[root] = build(k + 1, ir, pl + (k - 1 - il) + 1, pr - 1);    //递归右子树
    return root;
}
//层次遍历
void bfs(int root)
{
    //初始化,用队列来模拟层次遍历
    int hh = 0, tt = 0;
    q[0] = root;
    //开始遍历
    while (hh <= tt)
    {
        int k = q[hh++];
        if (l.count(k))  q[++tt] = l[k];
        if (r.count(k))  q[++tt] = r[k];
    }
    //输出结果
    cout << q[0];
    for (int i = 1; i < n; i++)    cout << " " << q[i];
    cout << endl;
}
int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> posorder[i];
    for (int i = 0; i < n; i++)
    {
        cin >> inorder[i];
        pos[inorder[i]] = i;  //记录该值在中序数组中的下标
    }
    int root = build(0, n - 1, 0, n - 1);
    bfs(root);
    return 0;
}



目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
85 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
79 0
|
3天前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
18 2
|
9天前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
36 5
|
15天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
47 4
|
17天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
44 4
|
2月前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
28 4