【PAT甲级 - C++题解】1020 Tree Traversals

简介: 【PAT甲级 - C++题解】1020 Tree Traversals

1020 Tree Traversals


Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:


For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
• 1
• 2
• 3

Sample Output:

4 1 6 3 5 7 2

题意


第一行包含整数 N ,表示二叉树的节点数。


第二行包含 N  个整数,表示二叉树的后序遍历。


第三行包含 N  个整数,表示二叉树的中序遍历。


输出一行 N 个整数,表示二叉树的层序遍历。


思路

  1. 由于题目给定每个结点的值都不同,所以可以用哈希表存储每个结点在中序数组中的下标,方便后续使用。
  2. 通过下标构建二叉树(其中 k-1-il 表示左子树结点个数):


443492e50bd94524bcbcae9245095e98.png


  1. 通过 bfs 进行层次遍历,并输出最终结果。

代码

#include<bits/stdc++.h>
using namespace std;
const int N = 40;
int n;
int posorder[N], inorder[N];
unordered_map<int, int> l, r, pos;
int q[N];
//构建树
int build(int il, int ir, int pl, int pr)
{
    int root = posorder[pr];  //获得根结点
    int k = pos[root];    //获得该结点在中序数组中的下标
    if (il < k)   l[root] = build(il, k - 1, pl, pl + (k - 1 - il));        //递归左子树
    if (k < ir)   r[root] = build(k + 1, ir, pl + (k - 1 - il) + 1, pr - 1);    //递归右子树
    return root;
}
//层次遍历
void bfs(int root)
{
    //初始化,用队列来模拟层次遍历
    int hh = 0, tt = 0;
    q[0] = root;
    //开始遍历
    while (hh <= tt)
    {
        int k = q[hh++];
        if (l.count(k))  q[++tt] = l[k];
        if (r.count(k))  q[++tt] = r[k];
    }
    //输出结果
    cout << q[0];
    for (int i = 1; i < n; i++)    cout << " " << q[i];
    cout << endl;
}
int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> posorder[i];
    for (int i = 0; i < n; i++)
    {
        cin >> inorder[i];
        pos[inorder[i]] = i;  //记录该值在中序数组中的下标
    }
    int root = build(0, n - 1, 0, n - 1);
    bfs(root);
    return 0;
}



目录
打赏
0
0
0
0
37
分享
相关文章
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
97 0
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
141 0
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
130 0
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
127 0
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
92 0
【C++篇】深度解析类与对象(下)
在上一篇博客中,我们学习了C++的基础类与对象概念,包括类的定义、对象的使用和构造函数的作用。在这一篇,我们将深入探讨C++类的一些重要特性,如构造函数的高级用法、类型转换、static成员、友元、内部类、匿名对象,以及对象拷贝优化等。这些内容可以帮助你更好地理解和应用面向对象编程的核心理念,提升代码的健壮性、灵活性和可维护性。
【C++进阶】特殊类设计 && 单例模式
通过对特殊类设计和单例模式的深入探讨,我们可以更好地设计和实现复杂的C++程序。特殊类设计提高了代码的安全性和可维护性,而单例模式则确保类的唯一实例性和全局访问性。理解并掌握这些高级设计技巧,对于提升C++编程水平至关重要。
45 16
类和对象(中 )C++
本文详细讲解了C++中的默认成员函数,包括构造函数、析构函数、拷贝构造函数、赋值运算符重载和取地址运算符重载等内容。重点分析了各函数的特点、使用场景及相互关系,如构造函数的主要任务是初始化对象,而非创建空间;析构函数用于清理资源;拷贝构造与赋值运算符的区别在于前者用于创建新对象,后者用于已存在的对象赋值。同时,文章还探讨了运算符重载的规则及其应用场景,并通过实例加深理解。最后强调,若类中存在资源管理,需显式定义拷贝构造和赋值运算符以避免浅拷贝问题。
类和对象(上)(C++)
本篇内容主要讲解了C++中类的相关知识,包括类的定义、实例化及this指针的作用。详细说明了类的定义格式、成员函数默认为inline、访问限定符(public、protected、private)的使用规则,以及class与struct的区别。同时分析了类实例化的概念,对象大小的计算规则和内存对齐原则。最后介绍了this指针的工作机制,解释了成员函数如何通过隐含的this指针区分不同对象的数据。这些知识点帮助我们更好地理解C++中类的封装性和对象的实现原理。
|
1月前
|
【c++】继承(继承的定义格式、赋值兼容转换、多继承、派生类默认成员函数规则、继承与友元、继承与静态成员)
本文深入探讨了C++中的继承机制,作为面向对象编程(OOP)的核心特性之一。继承通过允许派生类扩展基类的属性和方法,极大促进了代码复用,增强了代码的可维护性和可扩展性。文章详细介绍了继承的基本概念、定义格式、继承方式(public、protected、private)、赋值兼容转换、作用域问题、默认成员函数规则、继承与友元、静态成员、多继承及菱形继承问题,并对比了继承与组合的优缺点。最后总结指出,虽然继承提高了代码灵活性和复用率,但也带来了耦合度高的问题,建议在“has-a”和“is-a”关系同时存在时优先使用组合。
93 6

热门文章

最新文章

AI助理

你好,我是AI助理

可以解答问题、推荐解决方案等