Mac上安装python失败,求解答-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

Mac上安装python失败,求解答

a123456678 2016-07-19 10:37:14 2510

MacBook-Air:~ Peter$ brew install python --host
Warning: You are using OS X 10.11.
We do not provide support for this pre-release version.
You may encounter build failures or other breakage.
==> Installing dependencies for python: sqlite, gdbm, makedepend
==> Installing python dependency: sqlite
==> Downloading https://sqlite.org/2015/sqlite-autoconf-3081101.tar.gz
Already downloaded: /Library/Caches/Homebrew/sqlite-3.8.11.1.tar.gz
==> ./configure --prefix=/usr/local/Cellar/sqlite/3.8.11.1 --enable-dynamic-exte
checking for suffix of executables...

checking whether we are cross compiling... **configure: error: in `/private/tmp/sqlite20151010-1990-1mkurp5/sqlite-autoconf-3081101':

configure: error: cannot run C compiled programs.

If you meant to cross compile, use `--host'.

See `config.log' for more details

**

READ THIS: https://git.io/brew-troubleshooting
--host
Warning: You are using OS X 10.11.
We do not provide support for this pre-release version.
You may encounter build failures or other breakage.

数据库管理 Python
分享到
取消 提交回答
全部回答(3)
  • jamesliu
    2019-07-17 19:58:18

    Mac本身就自带Python,但是版本有点低。我的Mac上是Python2.7. 然后我是在Python官网上下载了Python安装包PKG安装的。

    0 0
  • 山下浪子
    2019-07-17 19:58:18

    mac难道不是本身就自带Python环境吗?

    0 0
  • a123456678
    2019-07-17 19:58:18

    虽说无论开头还是结尾都已经说了不支持吧2333。。。。。
    不过用uname -m看一下平台,然后configure的时候加上host参数试一下?(--host=你的平台

    0 0
添加回答
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

推荐文章
相似问题