开发者社区 > 大数据与机器学习 > 人工智能平台PAI > 正文

机器学习PAI alink不支持flink 1.13以上的版本吗?

机器学习PAI alink不支持flink 1.13以上的版本吗?可以自己编译源码来支持吗

展开
收起
你鞋带开了~ 2024-02-18 22:47:57 50 0
5 条回答
写回答
取消 提交回答
  • 是的。Alink支持的Flink版本为1.13。Alink提供了pyalink包,这个包对应于Alink所支持的最新Flink版本,也就是1.13。请注意,不同版本的Alink可能对应不同版本的Flink,因此,如果正在使用特定版本的Alink,需要确保它支持正在使用的Flink版本。

    2024-02-19 14:46:10
    赞同 展开评论 打赏
  • 面对过去,不要迷离;面对未来,不必彷徨;活在今天,你只要把自己完全展示给别人看。

    机器学习PAI(Platform AI)的Alink组件目前支持Flink版本1.13,并且有可能通过自行编译源码来适配更高版本的Flink

    Alink是阿里巴巴计算平台事业部PAI团队基于实时计算引擎Apache Flink研发的机器学习算法平台。它提供了丰富的算法组件库和便捷的操作框架,使得开发者能够轻松搭建覆盖数据处理、特征工程、模型训练等环节的机器学习流水线。根据官方信息,Alink支持的Flink版本为1.13,这意味着在这个版本上,Alink能够提供最佳的兼容性和性能保证。

    如果您希望在Flink 1.13以上的版本中使用Alink,可能需要考虑以下几个方面:

    1. 检查官方文档:查看最新的官方文档或发布说明,了解Alink是否已经支持更高版本的Flink。
    2. 社区支持:在Alink的社区或论坛中寻求帮助,看看是否有其他开发者已经成功地将Alink适配到更高的Flink版本。
    3. 自行编译:如果官方尚未提供支持,您可以尝试自行编译Alink的源码,以适配您所需的Flink版本。这通常需要一定的技术能力和对Alink及Flink内部结构的理解。
    4. 等待更新:如果自行编译存在困难,您可能需要等待Alink官方发布支持更高版本Flink的更新。
    2024-02-19 13:14:06
    赞同 展开评论 打赏
  • 阿里云机器学习PAI的Alink是一个基于Apache Flink构建的大数据机器学习算法库,它与Flink的版本兼容性依赖于Alink自身发布的支持情况。

    关于您的问题,如果官方提供的Alink发行版尚未直接支持Flink 1.13或更高版本,理论上可以通过以下方式尝试:

    1. 查看最新版本
      首先检查Alink最新的稳定版是否已经支持了您所需的Flink版本。随着时间推移和项目更新,Alink有可能已经增加了对新版本Flink的支持。

    2. 源码编译
      如果当前版本的Alink尚不支持Flink 1.13及以上版本,您可以尝试从Alink的GitHub仓库获取源代码,并尝试将Flink相关依赖升级到1.13以上版本进行编译。但是需要注意的是,这需要解决可能出现的API不兼容性、功能变更等问题,确保所有Alink内部使用的Flink API在新版本中仍然有效。

    3. 社区沟通
      在进行上述操作之前,建议在Alink的社区论坛或者GitHub issues中寻找是否有类似问题的讨论,了解社区是否已经在处理这个问题,或者是否有其他开发者成功进行了这样的升级实践。

    4. 等待官方支持
      如果自行升级存在困难,最好的办法是关注Alink的官方发布动态,等待官方正式支持对应的Flink新版本。

    总之,在尝试自己编译以支持更高版本的Flink时,请务必谨慎并做好充分的测试,以保证系统的稳定性和正确性。同时也要考虑到官方不推荐使用的版本可能存在未公开的已知问题或安全风险。

    2024-02-19 10:26:46
    赞同 展开评论 打赏
  • 北京阿里云ACE会长

    image.png

    是的,PAI Alink 目前不支持 Flink 1.13 及其以上的版本。PAI Alink 是在 Flink 1.11 基础上开发的,其依赖的 Flink 版本较旧,因此无法直接支持 Flink 1.13 及其以上的版本。
    如果您需要使用 Flink 1.13 及其以上的版本,可以尝试自行编译 Alink 的源码。但是,需要注意的是,编译过程中可能会遇到一些兼容性问题,因为 Alink 的源码是基于 Flink 1.11 开发的。要解决这些问题,您可能需要对源码进行一定的修改和调整。这可能会是一个复杂且耗时的过程,因此请谨慎操作。

    image.png

    2024-02-19 08:51:09
    赞同 展开评论 打赏
  • 十分耕耘,一定会有一分收获!

    楼主你好,据我所知目前阿里云机器学习PAI alink不支持Flink 1.13以上的版本,阿里云官方还没有发布对Flink 1.13以上版本的支持。

    如果你想要使用Flink 1.13以上版本,可以自己尝试编译源码来支持,在GitHub上有Flink的源码仓库,你可以下载源码并按照Flink官方的文档进行编译和安装。

    2024-02-19 08:53:27
    赞同 展开评论 打赏

热门讨论

热门文章

相关电子书

更多
Flink CDC Meetup PPT - 龚中强 立即下载
Flink CDC Meetup PPT - 王赫 立即下载
Flink CDC Meetup PPT - 覃立辉 立即下载